Bug 195690 - xsltproc fails under selinux
Summary: xsltproc fails under selinux
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libxslt   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-16 16:32 UTC by Kjartan Maraas
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-16 11:49:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kjartan Maraas 2006-06-16 16:32:59 UTC
Description of problem:
I have to run with setenforce 0 to get gnome modules to build in a jhbuild
environment because xsltproc fails with selinux.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Daniel Veillard 2006-06-17 21:37:31 UTC
I don't see how this can be xsltproc cause. Maybe it needs to access
or write to paths which are not allowed to load the document for the
transformation, or to save the output of the transformation if --output
argument is provided . But in any case it sounds like a context problem
either in the gnome documentation tools or in the output parameter, or
in the DocBook DTDs themselves.
I don't think libxslt is really guilty here, and without the error messages
it's hard to tell who is at fault, so please provide the errors or sufficient
context.

Daniel

Comment 2 Kjartan Maraas 2006-06-18 16:47:42 UTC
Here's the error message. Maybe it's a problem with libgcrypt.so instead?

xsltproc -o gnome-doc-make-C.omf --stringparam db2omf.basename gnome-doc-make
--stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD
DocBook XML V4.4//EN" --stringparam db2omf.lang C --stringparam db2omf.omf_dir
"/opt/gnome2/share/omf" --stringparam db2omf.help_dir
"/opt/gnome2/share/gnome/help" --stringparam db2omf.omf_in
"`pwd`/./gnome-doc-make.omf.in" ../../xslt/docbook/omf/db2omf.xsl
C/gnome-doc-make.xml
xsltproc: error while loading shared libraries: libgcrypt.so.11: cannot enable
executable stack as shared object requires: Permission denied
make[2]: *** [gnome-doc-make-C.omf] Error 127


Comment 3 Daniel Veillard 2006-11-02 15:57:23 UTC
sounds like a gcrypt compilation problem, I hope this has been fixed in recent
releases, can you confirm ?

Daniel

Comment 4 Kjartan Maraas 2007-10-16 11:49:08 UTC
Works for me now. Closing.


Note You need to log in before you can comment on or make changes to this bug.