Bug 195696 - [RHEL 3 U8]Manual kernel compile on PPC iSeries gives a symbol error
[RHEL 3 U8]Manual kernel compile on PPC iSeries gives a symbol error
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-16 13:28 EDT by Joshua Giles
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 08:53:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Giles 2006-06-16 13:28:56 EDT
Description of problem:
After a manual compilation of 2.4.21-44 kernel and upon executing:
"make modules_install"  I see a module with unresolved symbols:
"depmod: *** Unresolved symbols in
/lib/modules/2.4.21-43.ELcustom/kernel/drivers/net/sb1000.o
depmod:         .insw"

Config file was the "kernel-2.4.21-ppc64iseries.config"

Version-Release number of selected component (if applicable):
2.4.21-44 and 2.4.21-43
*Not a regression


How reproducible:
100%

Steps to Reproduce:
1.make mrproper && make oldconfig && make dep boot modules modules_install
2.
3.
  
Actual results:
depmod: *** Unresolved symbols in
/lib/modules/2.4.21-43.ELcustom/kernel/drivers/net/sb1000.o
depmod:         .insw

Expected results:
No symbol errors.

Additional info:
I'm not certain how often the sb1000 General Instruments Network card is on a
PPC Iseries, but this doesn't appear to be a high priority item at this stage.
Comment 1 Ernie Petrides 2006-06-16 17:01:56 EDT
Thanks, Josh.  Since this is not a U8 regression, I'm going to change
the product to RHEL (non-beta) and version to 3.

As an FYI to any developer who might look at this, the "sb1000" driver
is listed in the "kernel-unsupported" list.  The warning could be
addressed by disabling CONFIG_NET_SB1000 in one of the ppc64-specific
config files, or possibly by fixing up header file includes (it might
be that include/asm-ppc64/io.h is not getting pulled in).
Comment 2 Prarit Bhargava 2007-09-13 08:53:15 EDT
Josh,

RHEL3 is closed.  I'm going to close this out at CANTFIX.

P.

Note You need to log in before you can comment on or make changes to this bug.