Bug 1957015 - [IPI baremetal] Two nodes hold the VIP post remove and start of the Keepalived container
Summary: [IPI baremetal] Two nodes hold the VIP post remove and start of the Keepaliv...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.7
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: 4.7.z
Assignee: Ben Nemec
QA Contact: Aleksandra Malykhin
URL:
Whiteboard:
: 1945619 (view as bug list)
Depends On: 1931505
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-04 20:53 UTC by Ben Nemec
Modified: 2021-05-19 15:17 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Keepalived did not properly clean up VIPs if it was force restarted by liveness probe (for example). Consequence: The VIP may appear on multiple nodes, which can cause problems connecting to services behind the VIP. Fix: Before starting keepalived, ensure that the configured VIPs are removed. Result: VIPs no longer show up on multiple nodes at once.
Clone Of: 1931505
Environment:
Last Closed: 2021-05-19 15:17:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 2566 0 None open Bug 1957015: [on-prem] Backport duplicate VIP fixes 2021-05-04 20:57:52 UTC
Red Hat Product Errata RHBA-2021:1550 0 None None None 2021-05-19 15:17:39 UTC

Comment 1 Ben Nemec 2021-05-04 21:00:35 UTC
*** Bug 1945619 has been marked as a duplicate of this bug. ***

Comment 2 Omri Hochman 2021-05-05 22:10:03 UTC
*** Bug 1945619 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2021-05-19 15:17:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1550


Note You need to log in before you can comment on or make changes to this bug.