Bug 1957059 - gnome software fails to load apps from external repo
Summary: gnome software fails to load apps from external repo
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-04 23:36 UTC by Seth Kenlon
Modified: 2021-05-05 06:45 UTC (History)
3 users (show)

Fixed In Version: gnome-software-40.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-05 06:45:58 UTC
Type: Bug


Attachments (Terms of Use)
Screenshot of Emacs from Flathub running next to Gnome Software with no listing for Emacs. Flathub repos is enabled (this window is from a separate screenshot and composited in for reference) (114.62 KB, image/jpeg)
2021-05-04 23:36 UTC, Seth Kenlon
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME/gnome-software - issues 1217 0 None None None 2021-05-05 06:45:54 UTC

Description Seth Kenlon 2021-05-04 23:36:06 UTC
Created attachment 1779603 [details]
Screenshot of Emacs from Flathub running next to Gnome Software with no listing for Emacs. Flathub repos is enabled (this window is from a separate screenshot and composited in for reference)

Description of problem:
After adding Flathub to Gnome Software, no applications from Flathub are available in Gnome Software.

Version-Release number of selected component (if applicable):
Fedora 34 Silverblue

How reproducible:
I've experienced this twice in a row (I reinstalled the whole OS to test)

Steps to Reproduce:
1. Install Fedora 34 Silverblue, reboot into system, setup account, start using it.
2. Open Gnome Software. Confirm that some application (Emacs or Syncthing or Glimpse, for instance) is not listed.
3. In Firefox, navigate to https://flatpak.org/setup/Fedora/ and download the Flathub Repository File (https://flathub.org/repo/flathub.flatpakrepo)
4. Open in Gnome Software when prompted.
5. Install Flathub repo.
6. Search for Emacs (or any app known to be in Flathub)
7. Try to force Gnome Software to update its listings; close it and reopen it, accept system updates if offered, wait several minutes.
8. Open Terminal. Do `flatpak search emacs` and see that Emacs is listed.
9. Install Emacs with `flatpak install org.gnu.emacs` and launch it to confirm that it's installed.
10. Open Gnome Software again, observe that Flathub is still not found.

Actual results:
Gnome Software eventually detects Flathub as a repo and lists applications, but I'm not sure whether it's just a matter of time, or a reboot, or a log out, or what.

Expected results:
If Gnome Software is awaiting a trigger, it should let the user know.
If a delay in propogation is expected, the user should be alerted.

Comment 1 Milan Crha 2021-05-05 06:45:58 UTC
Thanks for a bug report. Rather than claiming the distribution version only, you should also claim the exact package versions, because the package versions can change, while the distribution version is still the same.

Anyway, this had been addressed upstream by [1]. The change is part of the 40.1 release.

[1] https://gitlab.gnome.org/GNOME/gnome-software/-/issues/1217


Note You need to log in before you can comment on or make changes to this bug.