Bug 195731 - Sound Card not functioning
Sound Card not functioning
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-16 16:45 EDT by Jaime Perez
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-03 10:41:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ALC 861 Data Doc (1023.28 KB, application/pdf)
2006-06-22 17:43 EDT, Jaime Perez
no flags Details

  None (edit)
Description Jaime Perez 2006-06-16 16:45:56 EDT
Description of problem:  While RHEL 4 U 4 is being installed, the Os
attempts to play the Sound Card with sys-config-soundcard which does not
procudes any output. While using aplay, any .wav file will produce a
dead loop. RHEL 4 U 3 with EL 34 does play .wav and sysconfig works. 


Version-Release number of selected component (if applicable):
Notice this on the Test Kernel EL 37 and now on the RHEL 4 U 4 kernel
39.

How reproducible:


Steps to Reproduce:
1. On RHEL 37 or 39, run sys-config-soundcard for the detection click
"Play test sound"
2. Run aplay [file].wav from the comand prompt for the dead looping
result
  
Actual results: 


Expected results: Sound card detected and aplay plays the file without any
looped reprecussions as with RHEL 4 U 3 with EL 34.  


Additional info:

dx2200 MT

Processor type
Celeron D Processor - 2.66 GHz,

Chipset
ATI Radeon Xpress 200

Memory description
256 MB PC2-5300 DDR2 SDRAM

Realtek ALC861 audio 

Integrated ATI Radeon X300
Comment 1 John W. Linville 2006-06-22 14:36:00 EDT
Well, that figures...U3 and previous versions did not have any specific 
support for ALC861, while U4 does.  So, if it worked before then it was mostly 
by accident...

Do you happen to know if upstream ALSA works on this device?

Can you provide the details of how the audio hardware is wired on this box 
(how many codecs, which I/O ports connect to which codec pins, etc)?

Does Red Hat have one of these boxes?  Any chance you could send me one?
Comment 2 Jaime Perez 2006-06-22 17:43:18 EDT
Created attachment 131394 [details]
ALC 861 Data Doc

This document can be obtained from
http://www.realtek.com.tw/products/products1-2.aspx?modelid=2005073
Comment 3 Jaime Perez 2006-06-22 17:45:01 EDT
Direct from Realtek specs url 
http://www.realtek.com.tw/products/products1-2.aspx?modelid=2005073

HD Audio Codecs
  	
	ALC861
  	Value HD Audio Codec
	
  	
	General Description
  	

The ALC861 7.1 Channel High Definition Audio codec with UAA (Universal Audio
Architecture), features four stereo DACs and one stereo ADC. The ALC861 is
designed for multimedia PC systems.

With 7.1 output channels, along with mixing, mute, and gain control functions,
the ALC861 provides an integrated audio solution for PCs. Parts of analog IO are
input and output capable, and three headphone amplifiers are also integrated to
drive earphones on front and rear panels.

The ALC861 supports S/PDIF output function and a sampling rate of up to 96kHz,
offering easy connection of PCs to high-quality consumer electronic products
such as AC-3 decoders/speakers, and mini disk devices.

The ALC861 supports host/soft audio from the Intel ICH chipset, and also from
any other HDA compatible audio controller. With EAX/Direct Sound 3D/I3DL2/A3D
compatibility, and software utilities like Karaoke mode, environment emulation,
software equalizer, and HRTF 3D positional audio, the ALC861 provides an
excellent entertainment package and game experience for PC users.

	Features
  	

    * Four Stereo DACs support 16/20/24-bit PCM format for 7.1 channel audio
solution
    * One stereo ADC supports 16-bit PCM format
    * Front/Surround/Cen/LFE/Side-Surround DACs support independent 48KHz/96KHz
sample rate
    * ADC supports 48K/96K sample rate
    * FRONT (port-D), LINE2 (port-E), and MIC2 (port-F) are stereo input and
output re-tasking
    * High-quality differential CD input
    * Two jack detection pins: each supports detection of up to 4 jacks
    * Supports 48KHz/96KHz S/PDIF output
    * Supports analog PCBEEP input
    * Integrates digital BEEP generator
    * Power support: Digital: 3.3V; Analog: 5.0V
    * 48-pin LQFP 'Green'  package
    * Meets Microsoft WHQL/WLP 2.0 audio requirements
    * EAX™ 1.0 & 2.0 compatible
    * Direct Sound 3D™ compatible
    * A3D™ compatible
    * I3DL2 compatible
    * HRTF 3D Positional Audio
    * Emulation of 26 sound environments to enhance gaming experience
    * 10-band Software Equalizer
    * Voice Cancellation and Key Shifting in Karaoke mode

	Applications
  	

    * Multimedia PCs
    * 3D PC Games
    * Information Appliances (IA)
    * Voice Recognition
    * Audio Conferencing
Comment 4 John W. Linville 2006-06-22 19:37:35 EDT
Well, thanks...but that is not what I need... :-(

Board designers (especially those from HP) are notorious for being "creative" 
about how they actually wire codecs to the physical jacks on the back of the 
motherboard.  That (i.e. "which I/O ports connect to which codec pins") is the 
information that I need.
Comment 5 Bryan Christ 2006-06-23 12:11:18 EDT
Would it be sufficient for us to provide you with shell access to the box?
Comment 6 John W. Linville 2006-06-23 12:43:27 EDT
Very likely not.  At the very least I would need someone with ears to verify 
results, and without the requested documentation a large amount of trial and 
error (verified by ear) required.
Comment 7 Chris Williams 2006-06-23 15:46:31 EDT
Ship to:
Chris Wiliams
Red Hat, Inc.
1801 Varsity Drive
Raleigh, NC 17606

Comment 8 Bryan Christ 2006-06-23 16:47:53 EDT
Chris,

I will ship this out to you on Monday.  Keep it as the dx2200 which I would have
sent anyway for the certification support requirement.  Do you follow me on that?

Bryan
Comment 13 John W. Linville 2007-01-03 10:41:50 EST
Closing this due to lack of hardware, etc.  Please reopen when the hardware 
becomes available.
Comment 14 Bryan Christ 2007-01-03 10:44:33 EST
Chris,

Did I not send one of these to you?  I believe I did.

Note You need to log in before you can comment on or make changes to this bug.