Bug 195745 - MySQL 4.1 from RHN dies under heavy load
MySQL 4.1 from RHN dies under heavy load
Status: CLOSED DUPLICATE of bug 183277
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mysql (Show other bugs)
4.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tom Lane
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-16 20:10 EDT by Jon Jensen
Modified: 2013-07-02 23:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-22 17:29:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Jensen 2006-06-16 20:10:46 EDT
Description of problem: Two of our customers have high-traffic websites backed
by MySQL 4.1 (RHN packages) on RHEL 4 (i386). One is using PHP, the other Perl.
Their database schemas are completely different. Both were using MyISAM tables
exclusively.

In the past couple of months they both started having their sites go down under
heavy load. Every time it happened, mysqld was still running, but not
responsive. Restarting mysqld restored access, but sometimes only minutes later
it would hang again. Then sometimes it would go a few days without hanging. We
never saw anything in the logs.

In both cases, we had them upgrade to MySQL 5.0 from MySQL AB's RPM packages,
and the problems immediately stopped.

We've used MySQL 4.1 from MySQL AB's own RPM packages on RHEL 3, and have never
had any problem with it.

Version-Release number of selected component (if applicable):
mysql-server-4.1.20-1.RHEL4.1, and I think also mysql-server-4.1.12-3.RHEL4.1

How reproducible: Not easily. Kind of a Heisenbug.

Sorry I don't have anything more concrete than this, but I thought it'd be best
to get a bug in here in case anyone else runs into the same problem, so we can
try to narrow it down.
Comment 1 Tom Lane 2006-06-16 20:40:07 EDT
Are you sure you've seen this since updating to 4.1.20?  It sounds a bit similar to some other reports 
against 4.1.12, eg bug #183277.
Comment 2 Jon Jensen 2006-06-16 21:01:34 EDT
You may be right. We solved the problem the first time several weeks before
4.1.20 was built (according to package date 2006-06-02). The second time was
only a few days ago, but it's quite possible they weren't using 4.1.20 yet. Our
problems didn't manifest themselves quite the same way as in bug #183277, but
it's close enough that this should probably be marked as a duplicate. Bugzilla's
not letting me do that, though ...

Thanks.
Comment 3 Tom Lane 2006-06-16 23:13:17 EDT
It's premature to mark as dup if we're not sure.  I'll leave this open for the moment.  Please run 4.1.20 for 
awhile and update this bug once you know if the problem's still there.
Comment 4 Tom Lane 2006-11-22 17:29:49 EST
Since I've not heard anything, I'm going to close this as a duplicate of bug
#183277.  Please re-open if you think it's not.

*** This bug has been marked as a duplicate of 183277 ***

Note You need to log in before you can comment on or make changes to this bug.