Bug 195759 - beagle needs libecal-1.2.so.3 to function which was removed by evolution-data-server update
beagle needs libecal-1.2.so.3 to function which was removed by evolution-data...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution-sharp (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-17 07:45 EDT by Walter Neumann
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: evolution-sharp-0.10.2-9.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-11 10:54:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Walter Neumann 2006-06-17 07:45:10 EDT
Description of problem: beagle fails to function because it wants
libecal-1.2.so.3 which was updated to libecal-1.2.so.6 by
evolution-data-server-1.6.2-1.fc5.1

Version-Release number of selected component (if applicable):
beagle-0.2.6-1.fc5.1

How reproducible: Run beagled and check the beagle log. It has aborted
prematurely because of the missing library


Steps to Reproduce: install current beagle from fedora updates
1.run beagled
2.check the logs after a while.
3.
  
Actual results:
beagle has reports missing libecal-1.2.so.3 It also fails to index most of my
directories.

Expected results:
no missing library and all directories indexed.
Note: it is not clear that failing to index directories is the same bug since it
hs nothing to do with indexing evolution folders, but it is hard to check until
the missing library is fixed.


Additional info:
This bug has also been reported by someone under a closed evolution-data-server
bug: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=194174
Comment 1 Alexander Larsson 2006-06-21 07:55:00 EDT
It seems it wasn't enought rebuilding evolution-sharp after the evo bump:

grep ecal
/usr/lib/mono/gac/evolution-sharp/2.0.0.0__457eed85bd9370df/evolution-sharp.dll.config

  <dllmap dll="ecal" target="libecal-1.2.so.3"/>

ls /usr/lib/libecal-1.2.so.*
/usr/lib/libecal-1.2.so.6  /usr/lib/libecal-1.2.so.6.0.0
Comment 2 Matthew Barnes 2006-07-03 19:52:53 EDT
Apparently, evolution-sharp's configure.in file has to be manually updated to
pick up the newer libecal.  I bumped the ECAL_SOVERSION variable from 3 to 6 and
rebuilt.  This should fix the problem.

evolution-sharp-0.10.2-9.5

Note You need to log in before you can comment on or make changes to this bug.