Bug 1957725 - bundle-upgrade from the traditional installed operator doesn't use the default registry image may cause the registry pod failed [NEEDINFO]
Summary: bundle-upgrade from the traditional installed operator doesn't use the defaul...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Operator SDK
Version: 4.8
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.8-premerge
Assignee: Rashmi Gottipati
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks: 1956382
TreeView+ depends on / blocked
 
Reported: 2021-05-06 10:57 UTC by Fan Jia
Modified: 2021-06-07 13:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-07 13:46:45 UTC
Target Upstream Version:
rgottipa: needinfo? (jesusr)


Attachments (Terms of Use)

Comment 1 Rashmi Gottipati 2021-05-11 18:36:27 UTC
I have tried to reproduce this bug on OpenShift release version 4.8.0-fc.3. I installed an etcd operator of version 0.9.2 traditionally using OLM, and have tried to run `bundle-upgrade` command and the operator upgraded the bundle to the next version that I provided i.e 0.9.4. 

#oc get csv
NAME                  DISPLAY   VERSION   REPLACES              PHASE
etcdoperator.v0.9.4   etcd      0.9.4     etcdoperator.v0.9.2   Succeeded

However, I noticed that the registry pod was failing and is in CrashLoopBackOff state as below, as mentioned in the bug description. 

quay-io-olmqe-etcd-bundle-0-9-4-share     0/1     CrashLoopBackOff


I'm investigating the root cause for this currently and I will post an update soon.

Comment 2 Rashmi Gottipati 2021-06-07 13:42:22 UTC
One of the assumptions of `run bundle-upgrade` command is that the newer operator bundle (that a user intends to upgrade to) should not exist in the index image, if the previous version of the operator bundle was installed traditionally using OLM. This will cause the registry pod to fail as the bundle is already added to the index that provides package and CSV. If an operator bundle was installed using OLM, the next versions of upgrades should not be using the default index image but should be using the index image obtained from the annotations in the catalog source. `bundle-upgrade` from the traditional installed operator not using default registry image is expected. 

To clarify the assumptions of `run bundle-upgrade`, I opened a documentation update PR:  https://github.com/operator-framework/operator-sdk/pull/4968


However, these kind of errors in pod logs should be reported well and visible to the user through the command output as opposed to having to look through logs of various pods/deployments. For this, I will be creating a feature request in SDK issues. I will post the link for it here once I create it. 

Closing this issue as it's not a bug and is the expected outcome.


Note You need to log in before you can comment on or make changes to this bug.