Bug 1957731 - Web console (GUI) crashes when displaying workloads of some projects
Summary: Web console (GUI) crashes when displaying workloads of some projects
Keywords:
Status: CLOSED DUPLICATE of bug 1961936
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.9.0
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-06 11:03 UTC by Sergio G.
Modified: 2021-06-18 06:45 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-18 06:45:14 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sergio G. 2021-05-06 11:03:48 UTC
Description of problem:
Web console crashes when displaying some project workloads.

On a project where the crash occurs, it occurs both when displaying project workload (administrator perspective) and Topology (Developer perspective).
Other pages work well for the project.
The project consist from only a few Kubernetes objects, not more than 10 at any time.

The crash occurs in browser in Javascript, cluster itself is unaffected. After the crash in topology view, the entire GUI has to be refreshed (i.e. full page refresh from browser). 

Here is trace printed on the page after the crash:

RangeError
Description:
Maximum call stack size exceeded

Component Trace:

in f
    in O
    in div
    in div
    in StackItem
    in div
    in Stack
    in div
    in Unknown
    in O
    in div
    in Data
    in StatusBox
    in Unknown
    in O
    in i
    in i
    in Unknown
    in Unknown
    in c
    in l
    in s
    in t
    in t
    in div
    in Data
    in StatusBox
    in div
    in Unknown
    in Unknown
    in Unknown
    in Unknown
    in O
    in Unknown
    in O
    in Unknown
    in o
    in DetailsPage
    in Ce
    in l
    in Unknown
    in O
    in t
    in t
    in div
    in div
    in section
    in PageSection
    in Unknown
    in O
    in div
    in div
    in DrawerMain
    in DrawerContent
    in div
    in Drawer
    in NotificationDrawer
    in Unknown
    in O
    in main
    in div
    in Page
    in div
    in DrawerContentBody
    in div
    in div
    in DrawerMain
    in DrawerContent
    in div
    in Drawer
    in Unknown
    in O
    in T
    in l
    in O
    in Unknown
    in O
    in t
    in t
    in t
    in t

Stack Trace:

RangeError: Maximum call stack size exceeded
    at https://console-openshift-console.apps.cluster.domain.tld/static/vendors~delete-revision~dev-console-deployImage~dev-console-edit~dev-console-import~dev-console-moda~ab5d55e7-chunk-bff7c229732a25f4e202.min.js:16:235269
    at Array.forEach (<anonymous>)
    at c (https://console-openshift-console.apps.cluster.domain.tld/static/vendors~delete-revision~dev-console-deployImage~dev-console-edit~dev-console-import~dev-console-moda~ab5d55e7-chunk-bff7c229732a25f4e202.min.js:16:235258)
    at https://console-openshift-console.apps.cluster.domain.tld/static/vendors~delete-revision~dev-console-deployImage~dev-console-edit~dev-console-import~dev-console-moda~ab5d55e7-chunk-bff7c229732a25f4e202.min.js:16:235269
    at Array.forEach (<anonymous>)
    at c (https://console-openshift-console.apps.cluster.domain.tld/static/vendors~delete-revision~dev-console-deployImage~dev-console-edit~dev-console-import~dev-console-moda~ab5d55e7-chunk-bff7c229732a25f4e202.min.js:16:235258)
    at https://console-openshift-console.apps.cluster.domain.tld/static/vendors~delete-revision~dev-console-deployImage~dev-console-edit~dev-console-import~dev-console-moda~ab5d55e7-chunk-bff7c229732a25f4e202.min.js:16:235269
    at Array.forEach (<anonymous>)
    at c (https://console-openshift-console.apps.cluster.domain.tld/static/vendors~delete-revision~dev-console-deployImage~dev-console-edit~dev-console-import~dev-console-moda~ab5d55e7-chunk-bff7c229732a25f4e202.min.js:16:235258)
    at https://console-openshift-console.apps.cluster.domain.tld/static/vendors~delete-revision~dev-console-deployImage~dev-console-edit~dev-console-import~dev-console-moda~ab5d55e7-chunk-bff7c229732a25f4e202.min.js:16:235269


Version-Release number of selected component (if applicable):
4.6

Comment 1 Sergio G. 2021-05-06 11:04:50 UTC
The issue is not dependeant of the role of the user as it happens for non cluster-admin and cluster-admins.

Comment 6 Jaivardhan Kumar 2021-05-19 05:46:28 UTC
This issue looks similar to https://bugzilla.redhat.com/show_bug.cgi?id=1920524 (as commented by Christian has a similar stack trace related to the issue) and so this issue should not be seen in 4.7 and did the cherry-pick for same in 4.6 (associated PR: https://github.com/openshift/console/pull/8971, BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1961936

Comment 7 Karthik Jeeyar 2021-05-24 10:42:28 UTC
4.6 cherry pick PR is merged and I couldn't reproduce this issue on 4.6.0-0.ci-2021-05-22-034447 build as it has the fix. This fix should be available next 4.6 z-stream release (4.6.31), which is planned for June 1st.

Comment 8 Jaivardhan Kumar 2021-06-18 06:45:14 UTC
Fix for this is available as part of https://bugzilla.redhat.com/show_bug.cgi?id=1961936 and I did verify it on 4.6.31 and couldn't see the issue. Hence marking it as duplicate. Feel free to reopen it you observe the issue in 4.6.31 and beyond.

*** This bug has been marked as a duplicate of bug 1961936 ***


Note You need to log in before you can comment on or make changes to this bug.