Bug 195781 - Driver sets display gamma to unusable value
Driver sets display gamma to unusable value
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-17 14:38 EDT by Ralf Ertzinger
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-02 14:44:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Ertzinger 2006-06-17 14:38:22 EDT
Description of problem:
Since the update to the version below the nv driver seems to honour the Gamma
value reported by my monitor (Eizo S1910). The display has a fixed gamma of 2.2.
Earlier versions of the driver, however, used to ignore that and Xorg used a
gamma of 1.0, for which the monitor is set. Thus, the picture looks quite awful
with the new gamma.

Setting "Gamma 1.0" in the Monitor section of /etc/X11/xorg.conf does not help,
either.

Version-Release number of selected component (if applicable):
xorg-x11-drv-nv-1.1.1-5

How reproducible:
Always

Steps to Reproduce:
1. Attach monitor which reports a gamma value via DDC
2. Look in Xorg log after startup for the gamma used
3.
  
Actual results:
Xorg uses the gamma value reported by the monitor, instead of 1.0 1.0 1.0 like
earlier releases

Expected results:
At least make this optional somehow.

Additional info:
Comment 1 Dennis Jacobfeuerborn 2006-06-18 19:37:22 EDT
I'm seeing the same thing. You can try starting X with "startx -- -gamma 1.0"
(or modifying the respective line in the gdm config accordingly) as a
workaround. That does the trick for me.
Comment 2 Joseph Sacco 2006-06-19 14:31:50 EDT
The 'xgamma' can be used to reset the gamma value.


-Joseph
Comment 3 Adam Jackson 2006-08-02 14:44:27 EDT
Actually a bug in xorg-x11-server, should be fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.