This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 195784 - NM starts named but doesn't use it
NM starts named but doesn't use it
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-17 14:48 EDT by Chris Adams
Modified: 2013-04-30 19:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-30 06:05:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Adams 2006-06-17 14:48:06 EDT
The NetworkManager init script starts named but doesn't appear to use it.  When
connecting to a network, /etc/resolv.conf points at the DHCP assigned name
servers (not the local named).
Comment 1 Dan Williams 2006-07-09 19:47:42 EDT
It appears that named doesn't get started with the -D option by default to
enable dbus.  Jason?
Comment 2 Dan Williams 2006-07-09 19:48:11 EDT
It appears that named doesn't get started with the -D option by default to
enable dbus.  Jason?
Comment 3 Jason Vas Dias 2006-07-19 17:45:30 EDT
This is now fixed with bind-9.3.2-30.fc6, and with bind-9.3.2-22.fc5, now being
released to FC-5 updates/testing.
Now, if the NetworkManager service is enabled in any runlevel, the named 
initscript will ensure that the named options contain -D.

Comment 4 Fedora Update System 2006-07-22 14:59:38 EDT
bind-9.3.2-22.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Adam Tkac 2007-05-30 06:05:44 EDT
Looks like fixed. If still exists, please reopen.

Regards, Adam

Note You need to log in before you can comment on or make changes to this bug.