Bug 195793 - can't install rhel4u3 via kickstart with static ip or dhcp
can't install rhel4u3 via kickstart with static ip or dhcp
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-17 16:57 EDT by Jun Yu
Modified: 2008-07-24 14:04 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 14:04:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jun Yu 2006-06-17 16:57:04 EDT
Description of problem:

1. boot the target server with rhel4u3 disc 1
2. at boot: prompt, input the string "linux ks=nfs:192.168.0.200:/install/ks.cfg
ksdevice=eth0 ip=192.168.0.113 netmask=255.255.255.0 gateway=192.168.0.1
dns=202.96.209.5
3.the target server 's main console show "Determining  host name and domain ..."
and nearly 20 seconds, it reported "That directory could not be mounted from the
server"
4. switch to ALT+F4 and it reported "loader:failed to set default route :
Network is unreachable"
5. the installation is Ok if i start the installation without kickstart by pass
the boot option " boot: linux askmethod" and choose NFS image installation.
6. i've double checked my nfs server, network connection, hardware healthy
status, target server's network connection status and sure these basic setting
are all OK. i can access the same nfs server from another production server
without any problem.

Very strange thing is :
i've also found one brief from redhat's knowledge base that describes the same
issue but said it will be  fixed in rhel4u1 and later version. So i can't
understand why this issue has appeared in U3 again ?

The Redhat knowledge base brief description the same problem is here
http://kbase.redhat.com/faq/FAQ_42_5549.shtm. ID:5549.
Comment 1 David Cantrell 2007-03-15 14:08:34 EDT
Please attach /tmp/anaconda.log so we can have a better idea of what is
happening.  You may also want to try the latest update release of RHEL4 or even
RHEL5 to see if the problem still exists there.
Comment 2 Denise Dumas 2008-07-24 14:04:07 EDT
Since we never received the requested log files, there's no way we're ever going
to be able to diagnose this. 

Note You need to log in before you can comment on or make changes to this bug.