Bug 195800 - wish: add option to yum to ignore unreachable repositories
wish: add option to yum to ignore unreachable repositories
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-17 17:43 EDT by Roland Wolters
Modified: 2014-01-21 17:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 16:48:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland Wolters 2006-06-17 17:43:00 EDT
(this wish was already filled, but lost due to the bugzilla crash)

Description of problem:
yum does not have a mechanism to automatically continue when a repository is 
unreachable. I think this should be implemented in one (or more) of the 
following ways:
1) A direct command line option (like "--norepofail") - the advantage would be 
that this could easily be integrated into existing scripts.
2) A repository specific option in /etc/repos.d/whatever.repo - the advantage 
would be that the user could choose the repositories where it is not critical 
if the download of repository information fails.
3) A plugin - since I'm not so familiar with the abilities of the plugin API 
I'm not sure if thi would work, but it could probably bring the needed 
features without changing yum itself, but with automatically activating it. 
And it could combine 1) and 2)

Reasons for this wish:
A standard installation of Fedora Core does not need this feature since the 
red hat network is stable enough.
However, fortunately more and more projects adopted the xml package metadata 
standard, and now there are more and more repos which will be activated inside 
of yum: skype, macromedia flash, ifolder client/server, mono, gstreamer, 
tapioca, etc. The opensuse build server will also provide repositories, making 
the list possibly much longer.

The problem is now that yum automatically fails when a repository is not 
reachable. A system administrator can always avoid this failing by 
deactivating the problematic repos on the fly (--disablerepo=...), but that's 
tricky in case of complicated automatic scripts or if you have a server which 
should just run, and where you don't want to correct something manually every 
day.

Also normal users which are used to the GUI are lost when pirut/pup cannot be 
started due to one single missing repository.
Comment 1 Jeremy Katz 2006-09-18 16:48:28 EDT
Ignoring an unreachable repository could end up having you pull an update that
you in no way expected to get.  There have been a number of threads about this
upstream and it's been veteoed each and every time
Comment 2 Roland Wolters 2006-09-19 05:30:43 EDT
Ok, please add a link where I can look into further discussions.

Note You need to log in before you can comment on or make changes to this bug.