Bug 1958016 - should update to 0.47.1 for prometheus-operator resources label
Summary: should update to 0.47.1 for prometheus-operator resources label
Keywords:
Status: CLOSED DUPLICATE of bug 1879495
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.8
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.8.0
Assignee: Haoyu Sun
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-07 02:52 UTC by Junqi Zhao
Modified: 2021-05-27 15:01 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-27 14:59:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 1182 0 None open Bug 1958016: should update to 0.47.1 for prometheus-operator resources label 2021-05-27 00:32:20 UTC

Description Junqi Zhao 2021-05-07 02:52:41 UTC
Description of problem:
Prometheus Operator version is bumped to 0.47.1, but the label is still 0.47.0, same for clusterrole/clusterrolebindings/deploy/service/ServiceAccount/servicemonitors/PrometheusRule prometheus-operator resources

# oc -n openshift-monitoring logs prometheus-operator-6d54b5894-lstdw -c prometheus-operator | head
level=warn ts=2021-05-07T01:52:59.16925351Z caller=main.go:282 msg="The '--config-reloader-cpu' flag has been deprecated! Please use '--config-reloader-cpu-limit' and '--config-reloader-cpu-request' according to your use-case."
level=warn ts=2021-05-07T01:52:59.169440991Z caller=main.go:285 msg="The '--config-reloader-memory' flag has been deprecated! Please use '--config-reloader-memory-limit' and '--config-reloader-memory-request' according to your use-case."
level=info ts=2021-05-07T01:52:59.169482509Z caller=main.go:294 msg="Starting Prometheus Operator" version="(version=0.47.1, branch=rhaos-4.8-rhel-8, revision=7229257)"
level=info ts=2021-05-07T01:52:59.169514367Z caller=main.go:295 build_context="(go=go1.16.1, user=root, date=20210505-11:40:58)"
level=info ts=2021-05-07T01:52:59.258724167Z caller=server.go:54 msg="enabling server side TLS"
level=info ts=2021-05-07T01:52:59.260273257Z caller=main.go:124 msg="Starting secure server on [::]:8080"
level=info ts=2021-05-07T01:52:59.275129971Z caller=operator.go:306 component=thanosoperator msg="connection established" cluster-version=v1.21.0-rc.0+291e731
level=info ts=2021-05-07T01:52:59.275380294Z caller=operator.go:315 component=thanosoperator msg="CRD API endpoints ready"
level=info ts=2021-05-07T01:52:59.275277609Z caller=operator.go:446 component=alertmanageroperator msg="connection established" cluster-version=v1.21.0-rc.0+291e731
level=info ts=2021-05-07T01:52:59.287548836Z caller=operator.go:455 component=alertmanageroperator msg="CRD API endpoints ready"

# oc -n openshift-monitoring get deploy prometheus-operator -oyaml | grep labels -A6
  labels:
    app.kubernetes.io/component: controller
    app.kubernetes.io/name: prometheus-operator
    app.kubernetes.io/part-of: openshift-monitoring
    app.kubernetes.io/version: 0.47.0
  name: prometheus-operator
  namespace: openshift-monitoring

# oc -n openshift-monitoring get pod prometheus-operator-6d54b5894-lstdw --show-labels 
NAME                                  READY   STATUS    RESTARTS   AGE   LABELS
prometheus-operator-6d54b5894-lstdw   2/2     Running   0          55m   app.kubernetes.io/component=controller,app.kubernetes.io/name=prometheus-operator,app.kubernetes.io/part-of=openshift-monitoring,app.kubernetes.io/version=0.47.0,pod-template-hash=6d54b5894

Version-Release number of selected component (if applicable):
4.8.0-0.nightly-2021-05-06-162549
Prometheus Operator 0.47.1

How reproducible:
always

Steps to Reproduce:
1. see the description
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Haoyu Sun 2021-05-27 14:59:54 UTC

*** This bug has been marked as a duplicate of bug 1879495 ***

Comment 2 Haoyu Sun 2021-05-27 15:01:54 UTC
Resolution of the bug will be tracked by bug 1879495, PR https://github.com/openshift/cluster-monitoring-operator/pull/1187


Note You need to log in before you can comment on or make changes to this bug.