Bug 1958037 - [Rados] Progress section - Global Recovery Event remaining time is increasing indefinitely after all pgs in active+clean
Summary: [Rados] Progress section - Global Recovery Event remaining time is increasing...
Keywords:
Status: CLOSED DUPLICATE of bug 1956601
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS
Version: 5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 5.1
Assignee: Neha Ojha
QA Contact: Manohar Murthy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-07 05:23 UTC by Vasishta
Modified: 2021-05-07 19:30 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-07 19:30:23 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Vasishta 2021-05-07 05:23:38 UTC
Description of problem:
Turned on PG autoscale in an upgraded cluster (from rhcs 4.x to rhcs 5.x)
After PGs were re-scaled, Remaining time of Global Recovery Event in progress section in ceph status seems to be increasing indefinitely
(observed increasing from 4s to 9h)

Version-Release number of selected component (if applicable):
16.2.0-26.el8cp

How reproducible:
1/3 attempts

Steps to Reproduce:
1. Configure 4.x cluster
2. upgrade it to 5.x
3. turn on pg autoscale on pools that were created in rhcs 4.x observe recovery

Actual results:
=------------------------------Before(In b/w recovery)----------
    pgs:     646 active+clean
 
  io:
    client:   2.7 KiB/s rd, 68 KiB/s wr, 2 op/s rd, 135 op/s wr
 
  progress:
    Global Recovery Event (4s)
      [............................] 
 

-------------------------------After------------------------------
    pgs:     561 active+clean
 
  io:
    client:   2.7 KiB/s rd, 2 op/s rd, 0 op/s wr
 
  progress:
    Global Recovery Event (90m)
      [===.........................] (remaining: 9h)
------------------------------------------------------------

Expected results:
Progress section should be accurate

Additional info:


Note You need to log in before you can comment on or make changes to this bug.