Bug 195811 - Anaconda refulses to install on a root (or /boot) of xfs
Anaconda refulses to install on a root (or /boot) of xfs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
: 198276 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-18 00:34 EDT by Remi Gauvin
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-18 09:28:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Remi Gauvin 2006-06-18 00:34:54 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. Install Fedora Core on a single XFS partition
2.
3.
  
Actual results:

The installation prevents you from doing this with a lame message about XFS not
working as a boot partiion

Expected results:

Install Fedora on an XFS partion, including the the /boot partion.  Grub (the
only boot loader provided by Fedora) a: supports xfs  and b: is installed in the
Master boot record by default, so there is no need for a bootable partition  to
begin with!

Additional info:
Comment 1 Jeremy Katz 2006-06-18 09:28:23 EDT
This is intentional.  While grub can read XFS filesystems, actually installing
the GRUB bits to an XFS problem has been a cause of endless problems due to the
XFS maintainers not providing "traditional" Linux fs semantics around sync and
the like.  The last incarnation of problems, we agreed with them that the best
thing to do was to require an ext[23] /boot fs for users wanting to use XFS
Comment 2 Jan Engelhardt 2006-07-10 16:08:01 EDT
Just install GRUB into the MBR and you should have no problem. Requires GRUB >=
0.97 because of a bug in earlier grubs wrt. xfs.
Comment 3 Phil Knirsch 2006-07-18 08:08:27 EDT
*** Bug 198276 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.