Bug 195820 - darcs requires SELinux allow_execmem=true priviledge
darcs requires SELinux allow_execmem=true priviledge
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: darcs (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
: Reopened
Depends On: 195821
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-18 04:12 EDT by Hans Ulrich Niedermann
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.0.8-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-29 23:07:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans Ulrich Niedermann 2006-06-18 04:12:31 EDT
Description of problem:

  darcs does not work at all unless the SELinux allow_execmem boolean
  is set to true.

  This seems to be caused by ghc, but as it nevertheless affects darcs,
  I am submitting this bug report as a reminder, and as a help for people
  running into the same problem.

Version-Release number of selected component (if applicable):

  darcs-1.0.7-1.fc5

How reproducible:

  Every time.


Steps to Reproduce:

  1. Run "darcs get --partial http://fasodjfasdhgjkhasdkjf.xyz/ajdlfk/"
     (you can also use a known good URL like http://iki.fi/tuomov/repos/ion-3/)

Actual results:

  darcs: internal error: getMBlock: mmap: Permission denied
      Please report this as a compiler bug.  See:
      http://www.haskell.org/ghc/reportabug

Expected results:

  Invalid repository:  http://fasodjfasdhgjkhasdkjf.xyz/ajdlfk

  darcs failed:  Failed to download URL http://fasodjfasdhgjkhasdkjf.xyz/ajdlfk/_d
  arcs/inventory
  libcurl: couldn't resolve host

Additional info:
Comment 1 Jens Petersen 2006-06-21 04:12:32 EDT
Thanks for the report.  Do you know how to fix this?
I'm not that familiar with selinux.
Comment 2 Jens Petersen 2006-06-21 04:22:07 EDT
This has been discussed upstream: <http://cvs.haskell.org/trac/ghc/ticket/738>.
Comment 3 Jens Petersen 2006-06-22 09:48:00 EDT

*** This bug has been marked as a duplicate of 195821 ***
Comment 4 Hans Ulrich Niedermann 2006-06-22 18:31:59 EDT
Are you sure this is a duplicate of the ghc bug?

After all, darcs (like all Haskell software) will have to be recompiled with a
new version of ghc once ghc bug #195821 has been fixed.

Marking darcs as requiring that recompilation (with this bug) makes sense,
doesn't it?
Comment 5 Jens Petersen 2006-06-22 21:17:15 EDT
Fair point - re-opening to track this for darcs.
Comment 6 Jens Petersen 2006-06-29 04:39:12 EDT
darcs-1.0.8-2.fc6 should have a fix for this.
Comment 7 Jens Petersen 2006-06-29 04:41:21 EDT
Could you test this on fc5?  It is ok I'll put out an update for fc5 too.

Is an update needed for fc4 too?
Comment 8 Jens Petersen 2006-06-29 23:07:43 EDT
I built the update for fc5.

Note You need to log in before you can comment on or make changes to this bug.