Bug 195822 - Glibc locales.
Glibc locales.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-18 04:25 EDT by Gennadi Sushko
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-18 05:17:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gennadi Sushko 2006-06-18 04:25:29 EDT
Description of problem:
Package glibc-common contains all supported locales. It can be split into 
separate locales (e.g. by language: ru en aa etc.). This will save nearly 150 
Mbs(+ 50Mbs because of locale-archive) to any Fedora installation.

Version-Release number of selected component (if applicable):
2.4-8

How reproducible:


Steps to Reproduce:
1. Install FC.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jakub Jelinek 2006-06-18 05:17:24 EDT
All locale related files are properly %lang() marked, so if you want to
only install a few locales, it is far better to just set %_install_langs
appropriately, say
%_install_langs ru en
in rpm configuration.  Splitting glibc-common is very bad idea, that would grow
things a lot, as many locale files are identical between dozens of locales and
are normally hardlinked together.

Note You need to log in before you can comment on or make changes to this bug.