This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 195837 - upgrade process stops when it detects package which it cannot verify
upgrade process stops when it detects package which it cannot verify
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-18 10:45 EDT by Vladimir Kotal
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-09 15:40:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
pup is about to exit (177.94 KB, image/png)
2006-06-18 10:52 EDT, Vladimir Kotal
no flags Details

  None (edit)
Description Vladimir Kotal 2006-06-18 10:45:50 EDT
Description of problem:
pup is not able to proceed with package upgrade if it detects package which it
cannot verify. this is very annoying, especially after number of packages were
downloaded.

Version-Release number of selected component (if applicable):
pirut-1.0.1-1

How reproducible:
try to upgrade with non-verifiable packages

Steps to Reproduce:
1. launch pup, hit upgrade button
2. wait for the dialog appears with 'unable to verify...'
  
Actual results:
pup exits upgrade process

Expected results:
it should continue the process. ideally, it should present errors after it exits
and not in the process itself.

Additional info:
proper user interface guidelines should be met in order to be usable software.
user experience is important.
Comment 1 Vladimir Kotal 2006-06-18 10:52:05 EDT
Created attachment 131119 [details]
pup is about to exit
Comment 2 Vladimir Kotal 2006-06-18 11:14:42 EDT
to clarify better: let's say a user want to upgrade all possible packages on my
system in one go. The user launches pup, click on upgrade button and pup starts
its process. Then it discoveres a package which it cannot verify and presents
error window. The user then has de-select offending package and click on the
upgrade button once more and the process starts again. Then again it discoveres
a package (different one), present error message and terminates process. Then
again, user has to start the process from the beginning. This is very
frustrating if number of packages cannot be verified.
Comment 3 Jeremy Katz 2006-06-19 17:21:57 EDT
This seems to be fixing the wrong problem, though.  Why can't the package be
verified?
Comment 4 Vladimir Kotal 2006-06-20 15:43:27 EDT
this is e.g. because of the missing PGP keys. I understand that you would like
to move the problem to the user but this will not change the fact that the
user-interface design is wrong - isn't it a flaw that it presents the errors one
by one ? even if this can be fixed by adding a key or removing package from
upgradeable set, it will be very annoying if multiple package sources will be
used. The administrator would still have to do it one by one.
Comment 5 Jeremy Katz 2007-04-09 15:40:29 EDT
The repo should be set up to point to the appropriate key, though.  Trying to
provide information about a lot of problems at once is likely to be equally
overwhelming as well as downloading things which the user may or may not want to
spend the time/bandwidth on.

Note You need to log in before you can comment on or make changes to this bug.