Bug 195842 - rpm overwrites personalised vpnc-script's
rpm overwrites personalised vpnc-script's
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vpnc (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-18 12:12 EDT by Chris Phillips
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: vpnc-0.3.3-15.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-17 18:10:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Phillips 2006-06-18 12:12:48 EDT
Description of problem:

upgrading of vpnc causes overwriting of personalized vpnc-script files, without
old version being backed up to vpnc-script.rpmsave or such like.

Version-Release number of selected component (if applicable):

current on FC5 Extras, presumed on all releases

How reproducible:

Always

Steps to Reproduce:
1. personalise vpnc-script file to suit needs
2. perform vpnc upgrade
  
Actual results:

changes to vpnc-script are permanently lost from system

Expected results:

either new vpnc-script file should be installed as vpnc-script.rpmnew or older
one should be backed up to vpnc-script.rpmsave.

Additional info:

official documentation states that this script should be personalised to suit
the needs of the user and type of network connection. as such users changes
should persist in some format across upgrades

Note You need to log in before you can comment on or make changes to this bug.