Bug 1958679 - Compression on pool can't be disabled via UI
Summary: Compression on pool can't be disabled via UI
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.7
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
: 4.8.0
Assignee: Sanjal Katiyar
QA Contact: Shay Rozen
Depends On:
TreeView+ depends on / blocked
Reported: 2021-05-09 17:54 UTC by Shay Rozen
Modified: 2021-07-27 23:07 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2021-07-27 23:07:32 UTC
Target Upstream Version:

Attachments (Terms of Use)
Rook log (764.87 KB, text/plain)
2021-05-09 17:54 UTC, Shay Rozen
no flags Details

System ID Private Priority Status Summary Last Updated
Github openshift console pull 8897 0 None open Bug 1958679: Disable pool compression via UI 2021-05-11 19:58:19 UTC
Red Hat Product Errata RHSA-2021:2438 0 None None None 2021-07-27 23:07:50 UTC

Description Shay Rozen 2021-05-09 17:54:05 UTC
Created attachment 1781354 [details]
Rook log

Created attachment 1781354 [details]
Rook log

Description of problem (please be detailed as possible and provide log
After creating a pool with compression, You can't disable the compression. The UI accept the change and also the pool CR but ceph is not aware of the change and rook logs show:
2021-05-09 17:14:27.359149 E | cephclient: failed to set property "compression_mode" to pool "np1" to "". failed to set pool property "compression_mode" on pool "np1": Error EINVAL: unrecognized compression mode ''

Version of all relevant components (if applicable):
ocp 4.8.0-0.nightly-2021-04-30-201824
ocs 4.8.0-374.ci 

Does this issue impact your ability to continue to work with the product
(please explain in detail what is the user impact)?
Cant disable compression on pool

Is there any workaround available to the best of your knowledge?
Tried through patch to set compression_mode to none instead of "" and it got updated

Rate from 1 - 5 the complexity of the scenario you performed that caused this
bug (1 - very simple, 5 - very complex)?

Can this issue reproducible?

Can this issue reproduce from the UI?

If this is a regression, please provide more details to justify this:

Steps to Reproduce:
1. Install ocs 4.8
2. Create a pool with compression
3. Edit the pool and uncheck compression

Actual results:
Pool CR is updated but in ceph level pool still use compression_mode aggressive

[srozen@localhost ~]$ ceph osd pool get np1 compression_mode
compression_mode: aggressive

And there is an error on rook log:
2021-05-09 17:13:17.799674 E | cephclient: failed to set property "compression_mode" to pool "np1" to "". failed to set pool property "compression_mode" on pool "np1": Error EINVAL: unrecognized compression mode ''

Expected results:
Ceph pool should be updated with compression_mode to none

Additional info:

This will give the same error in rook:
This will also not work while using none instead of "" (which throw the same rook log) will work.
[srozen@localhost ~]$ oc patch cephblockpools.ceph.rook.io np1  --type merge -p '{"spec":{"parameters":{"compression_mode":""}}}'

Comment 2 Shay Rozen 2021-05-09 17:56:44 UTC
From No compression to compression the change is working. Only from compression to no compression there is an issue

Comment 3 Travis Nielsen 2021-05-11 15:03:07 UTC
The CephBlockPool CR needs to have the following instead of the empty string, to avoid ceph hitting that error. UI team, can we set this instead?

  compression_mode: none

Comment 5 Shay Rozen 2021-05-31 11:06:40 UTC
Verified on

ocp 4.8.0-0.nightly-2021-05-21-233425
ocs 4.8.0-399.ci

Comment 8 errata-xmlrpc 2021-07-27 23:07:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: OpenShift Container Platform 4.8.2 bug fix and security update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.