Bug 1958889 - Pinebook Pro: no display on eDP after: cdn-dp fec00000.dp: [drm:cdn_dp_probe [rockchipdrm]] *ERROR* missing extcon or phy
Summary: Pinebook Pro: no display on eDP after: cdn-dp fec00000.dp: [drm:cdn_dp_probe ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 34
Hardware: aarch64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-10 11:32 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2021-05-20 10:07 UTC (History)
18 users (show)

Fixed In Version: kernel-5.12.5-300.fc34.aarch64
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-20 10:07:48 UTC
Type: Bug


Attachments (Terms of Use)
F34 dmesg from first boot after installation (67.95 KB, text/plain)
2021-05-10 11:32 UTC, Dominik 'Rathann' Mierzejewski
no flags Details

Description Dominik 'Rathann' Mierzejewski 2021-05-10 11:32:47 UTC
Created attachment 1781669 [details]
F34 dmesg from first boot after installation

1. Please describe the problem:
The display goes blank after panfrost/rockchipdrm module is loaded. This happens on all F34 DVD ISO images (Workstation and KDE).

2. What is the Version-Release number of the kernel:
5.11.12-300.fc34.aarch64

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :
Unknown. These are the F34 GA DVD ISO images.

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:
Write one of the images below on a USB stick and boot Pinebook Pro from it:
https://download.fedoraproject.org/pub/fedora/linux/releases/34/Workstation/aarch64/iso/Fedora-Workstation-Live-aarch64-34-1.2.iso
https://download.fedoraproject.org/pub/fedora-secondary/releases/34/Spins/aarch64/iso/Fedora-KDE-Live-aarch64-34-1.2.iso

sudo dd if=./Fedora-KDE-Live-aarch64-34-1.2.iso status=progress bs=1M of=/dev/sde
Flash U-Boot to SPI (https://nullr0ute.com/2021/05/fedora-on-the-pinebook-pro/), reboot and boot from USB at U-Boot prompt:
=> run bootcmd_usb0

After booting the kernel, some of the messages scroll quickly at the top of the screen and then it goes blank. I only get output on the serial console.

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:
Unknown, I haven't tried yet.

6. Are you running any modules that not shipped with directly Fedora's kernel?:

No.

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Comment 1 Dominik 'Rathann' Mierzejewski 2021-05-10 11:33:37 UTC
https://lists.infradead.org/pipermail/linux-rockchip/2020-September/022453.html seems to be related.

Comment 2 Dominik 'Rathann' Mierzejewski 2021-05-20 10:07:48 UTC
FYI this is fixed by 5.12.5 that just hit updates-testing.


Note You need to log in before you can comment on or make changes to this bug.