Bug 1958908 - python-wcmatch fails to build with Python 3.10: TypeError: PurePath._from_parts() got an unexpected keyword argument 'init'
Summary: python-wcmatch fails to build with Python 3.10: TypeError: PurePath._from_par...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: python-wcmatch
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Parag Nemade
QA Contact:
URL:
Whiteboard:
: 1969169 (view as bug list)
Depends On:
Blocks: F35FTBFS F35FailsToInstall PYTHON3.10 1968775
TreeView+ depends on / blocked
 
Reported: 2021-05-10 12:11 UTC by Miro Hrončok
Modified: 2021-06-22 02:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-21 07:50:26 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github facelessuser wcmatch issues 176 0 None open Python 3.10: TypeError: PurePath._from_parts() got an unexpected keyword argument 'init' 2021-05-10 12:14:36 UTC

Description Miro Hrončok 2021-05-10 12:11:46 UTC
python-wcmatch fails to build with Python 3.10.0b1:


...
______________________ TestCWD.test_cwd_root_dir_pathlike ______________________
self = <tests.test_glob.TestCWD object at 0x7f4b20972bf0>
    def test_cwd_root_dir_pathlike(self):
        """Test root level glob when we switch directory via `root_dir` with a path-like object."""
    
>       self.assert_equal(glob.glob('EF', root_dir=pathlib.Path(self.tempdir)), ['EF'])
tests/test_glob.py:1136: 
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
cls = <class 'wcmatch.pathlib.PosixPath'>, args = ('@test_188_tmp_dir',)
kwargs = {}
    def __new__(cls, *args, **kwargs):
        """New."""
    
        if cls is Path:
            cls = WindowsPath if os.name == 'nt' else PosixPath
>       self = cls._from_parts(args, init=False)
E       TypeError: PurePath._from_parts() got an unexpected keyword argument 'init'
wcmatch/pathlib.py:80: TypeError
...
FAILED tests/test_glob.py::TestCWD::test_cwd_root_dir_pathlike - TypeError: P...
FAILED tests/test_globmatch.py::TestGlobMatchSpecial::test_filter_root_dir_pathlib
FAILED tests/test_globmatch.py::TestGlobMatchSpecial::test_match_root_dir_pathlib
FAILED tests/test_pathlib.py::TestGlob::test_glob - TypeError: PurePath._from...
FAILED tests/test_pathlib.py::TestGlob::test_integrity - TypeError: PurePath....
FAILED tests/test_pathlib.py::TestGlob::test_relative - TypeError: PurePath._...
FAILED tests/test_pathlib.py::TestGlob::test_relative_exclude - TypeError: Pu...
FAILED tests/test_pathlib.py::TestGlob::test_rglob - TypeError: PurePath._fro...
FAILED tests/test_pathlib.py::TestPathlibGlobmatch::test_cases[case0] - TypeE...
FAILED tests/test_pathlib.py::TestPathlibGlobmatch::test_cases[case1] - TypeE...
FAILED tests/test_pathlib.py::TestPathlibGlobmatch::test_cases[case2] - TypeE...
FAILED tests/test_pathlib.py::TestPathlibGlobmatch::test_cases[case3] - TypeE...
FAILED tests/test_pathlib.py::TestPathlibGlobmatch::test_cases[case4] - TypeE...
FAILED tests/test_pathlib.py::TestPathlibGlobmatch::test_cases[case5] - TypeE...
FAILED tests/test_pathlib.py::TestPathlibMatch::test_cases[case0] - TypeError...
FAILED tests/test_pathlib.py::TestPathlibMatch::test_cases[case1] - TypeError...
FAILED tests/test_pathlib.py::TestPathlibMatch::test_cases[case2] - TypeError...
FAILED tests/test_pathlib.py::TestPathlibMatch::test_cases[case3] - TypeError...
FAILED tests/test_pathlib.py::TestPathlibMatch::test_cases[case4] - TypeError...
FAILED tests/test_pathlib.py::TestPathlibMatch::test_cases[case5] - TypeError...
FAILED tests/test_pathlib.py::TestExceptions::test_absolute_glob - TypeError:...
FAILED tests/test_pathlib.py::TestExceptions::test_bad_path - TypeError: Pure...
FAILED tests/test_pathlib.py::TestExceptions::test_inverse_absolute_glob - Ty...
FAILED tests/test_pathlib.py::TestComparisons::test_equal - TypeError: PurePa...
FAILED tests/test_pathlib.py::TestComparisons::test_flavour_equal - TypeError...
FAILED tests/test_pathlib.py::TestComparisons::test_instance - TypeError: Pur...
FAILED tests/test_pathlib.py::TestComparisons::test_pickle - TypeError: PureP...
FAILED tests/test_pathlib.py::TestExpansionLimit::test_limit_glob - TypeError...
FAILED tests/test_pathlib.py::TestExpansionLimit::test_limit_rglob - TypeErro...
========== 29 failed, 1112 passed, 148 skipped, 1 deselected in 4.35s ==========


This was broken by https://bugs.python.org/issue40038 

It seems that wcmatch carries it's own pathlib implementation that needs to be adapted.


For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/02172626-python-wcmatch/

For all our attempts to build python-wcmatch with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-wcmatch/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2021-05-10 12:14:37 UTC
I went ahead and reported this to upstream: https://github.com/facelessuser/wcmatch/issues/176

Comment 2 Miro Hrončok 2021-06-04 20:15:19 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 3 Miro Hrončok 2021-06-07 22:59:46 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 4 Miro Hrončok 2021-06-08 11:35:39 UTC
*** Bug 1969169 has been marked as a duplicate of this bug. ***

Comment 5 Miro Hrončok 2021-06-15 20:27:44 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 6 Miro Hrončok 2021-06-21 07:50:26 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 35.

Thanks for taking care of it!


Note You need to log in before you can comment on or make changes to this bug.