Bug 195896 - hal-cups-utils requires SELinux policy change
hal-cups-utils requires SELinux policy change
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-06-19 08:53 EDT by Tim Waugh
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-16 06:47:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cups.patch (1.93 KB, text/x-patch)
2006-06-19 08:53 EDT, Tim Waugh
no flags Details

  None (edit)
Description Tim Waugh 2006-06-19 08:53:09 EDT
Description of problem:
I had filed this before and only just realised that it must have been one of the
bugs that got removed in the database failure. :-(((

hal-cups-utils needs to be able to configure CUPS over IPP, and so it needs some
extra SELinux policy.

Additionally, the hal_lpadmin tool has moved to /usr/libexec.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.2.47-1

How reproducible:
100%

Steps to Reproduce:
1. Plug in a USB printer.
  
Actual results:
No queue is created.

Additional info:
I've tested with the attached patch and it fixes it.
Comment 1 Tim Waugh 2006-06-19 08:53:09 EDT
Created attachment 131132 [details]
cups.patch
Comment 2 Tim Waugh 2006-06-19 08:55:09 EDT
If we could get this in for FC6test1 I would really appreciate it!
Comment 3 Daniel Walsh 2006-07-11 14:11:59 EDT
I believe all the changes are in test1.
Comment 4 Tim Waugh 2006-08-16 06:47:57 EDT
Thanks!

Note You need to log in before you can comment on or make changes to this bug.