Bug 195899 - dd (driver disk) not working with fc5, works with centos4
dd (driver disk) not working with fc5, works with centos4
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-19 09:27 EDT by Pasi Karkkainen
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-14 15:04:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pasi Karkkainen 2006-06-19 09:27:02 EDT
Description of problem:

My iSCSI HBA is not supported with the default FC5 kernel/drivers,
so I need to build dd (driver disk) image myself for qla4xxx HBA. 

I have built dd (floppy) image for FC5 using ddiskit 0.9.5, and
added missing files (modules.pcimap and pci.ids) manually. 

Missing files are taken from "official" Qlogic rhel4 dd image.

dd image contains modules built for 2.6.15-1.2054_FC5 (i586 and i686) 
and 2.6.15-1.2054_FC5smp.

The problem is that the FC5 installer won't load this dd image. 
Installer says "Reading driver disk", and after that "No devices
of the appropriate type were found on this driver disk".

In VC3 I see:

"INFO  trying to mount sdb"
"INFO  modules to insert"
"INFO  load module set done"

For some reason the installer doesn't even try to load the module.. ?

Same kind of selfmade image works very well in centos 4.2 and 4.3
installers.. only difference between the fc5 and centos4.x dd images are 
the driver modules being compiled for different kernel versions.

I've checked the pci/device ids and they are correct in the dd image.
lspci -n shows the same ids for the HBA.

Centos 4.3 with the selfmade dd works fine in the same box.

More information here: http://forums.fedoraforum.org/showthread.php?t=113660

Version-Release number of selected component (if applicable): FC5


How reproducible: Always. Just try to use the dd.


Steps to Reproduce:
1. Boot FC5 install with "linux dd"
2. Insert the driver disk (dd), or use http-url at step 1.
3. Get error message.
  
Actual results:
qla4xxx driver is not loaded

Expected results:
qla4xxx driver should have been loaded

Additional info: http://forums.fedoraforum.org/showthread.php?t=113660
Comment 1 Pasi Karkkainen 2006-06-19 09:30:05 EDT
Forgot to mention that if I go to VC2 (during the installer) and extract the
i586 driver module from the dd image, I can insmod it successfully and the
driver works.

Comment 2 Jeremy Katz 2006-06-19 20:47:10 EDT
Do you have a modinfo file? 
Comment 3 Pasi Karkkainen 2006-06-20 02:57:54 EDT
Yes I do have.

$ ls
modinfo  modules.cgz  modules.dep  modules.pcimap  pci.ids  pcitable  rhdd

You can see the contents of the dd image here:
http://forums.fedoraforum.org/showpost.php?p=553962&postcount=7

Comment 4 Pasi Karkkainen 2006-06-20 02:58:43 EDT
Yes I do have.

$ ls
modinfo  modules.cgz  modules.dep  modules.pcimap  pci.ids  pcitable  rhdd

You can see the contents of the dd image here:
http://forums.fedoraforum.org/showpost.php?p=553962&postcount=7
Comment 5 Pasi Karkkainen 2006-06-21 11:14:32 EDT
If there's something I could try, please tell.. I really would like to get this
working. 

Do you guys have a link to (some other) dd-image for fc5, which is known to
work? I could try to search for differences..

Most probably the problem is not in the modules itself, since I can successfully
load them (with insmod) when I manually extract them from dd image during the
fc5 installer.. 

And dd-image made in the exactly same way works in centos4/rhel4.. which is odd.

Thanks!
Comment 6 Pasi Karkkainen 2006-06-22 06:12:18 EDT
$ lspci -n | grep 1077
06:01.0 Class 0200: 1077:3022 (rev 02)
06:01.1 Class 0280: 1077:4022 (rev 02)
06:01.2 Class 0200: 1077:3022 (rev 02)
06:01.3 Class 0280: 1077:4022 (rev 02)

There are two HBA's in this machine (or in fact one dual-port HBA - but it is
seen as two separate HBA's).

Other device (3022) is the Ethernet device.. there is separate driver for that.

I also checked fc5 dd image from: http://rajibchy.tripod.com/

It's in different (old) format.. should I try using the old format? 
Comment 7 Pasi Karkkainen 2006-06-29 06:07:45 EDT
Also generated the driver disk image for fc6test1 and tried it.. same results /
errors :(

Any tips what I should try next? How can I debug this? 

The modules/drivers itself are OK, and load fine with insmod (during the
installer).. but the dd image itself doesn't work.. PCI ids are correct etc.. I
just can't figure out why the installer refuses to load the dd.

Looking at the anaconda repository these has been quite a lot of changes after
rhel4.. same kind of images work OK with rhel4, but not with fc5/fc6..
Comment 8 Pasi Karkkainen 2006-07-31 11:37:32 EDT
Another note: It looks like (looking at VC3) when I try to load the qla4xxx dd,
anaconda for some unknown reason loads tg3 driver instead of qla4xxx. Then on
the next try, I get that "No devices of the appropriate type were found on this
driver disk" error.

Comment 10 Pasi Karkkainen 2006-08-11 03:50:06 EDT
I have put my dd image for fc6 test1 available online:

http://pasik.reaktio.net/qla4xxx-v50007d2-fc6t1-driver-disk-dd.img

Please check it out..

Comment 11 Pasi Karkkainen 2006-08-24 03:30:41 EDT
Any comments about that dd image? 

No plans to sort this out for fc6?
Comment 12 Pasi Karkkainen 2006-09-07 13:37:01 EDT
Tested with FC6 test2 now.. 

http://pasik.reaktio.net/fc-dd/

There you can find dd-image for FC6 test2. 

I have also put the error messages I get during installer there.. for some
reason the driver disk is not detected as ext2 now?

$ file qla4xxx-v50007d2-fc6t2-driver-disk-dd-ext2.img
qla4xxx-v50007d2-fc6t2-driver-disk-dd-ext2.img: Linux rev 1.0 ext2 filesystem data

It definitely is.. and I can loop-mount it OK etc.. 

Please, check out the dd-image and comment.. I'd really would like to get this
sorted out.

Comment 13 Pasi Karkkainen 2006-09-13 14:19:26 EDT
Uploaded new driver disk CD-images also.. no luck with them either :(

http://pasik.reaktio.net/fc-dd/
http://pasik.reaktio.net/fc-dd/problem_screenshots/

In the screenshots you can see that when anaconda should load "qla4xxx" module,
it loads tg3 instead.. no idea why. 

And if I load the driver disk images over http (so the tg3 is already loaded),
anaconda won't do anything with the driver disk.. I just get error "no devices
of the appropriate type were found on this driver disk". 

Comment 14 Pasi Karkkainen 2006-09-13 14:41:33 EDT
Jeremy Katz on #fedora-devel told me that "some things have changed quite a bit
since rhel4 -- driver disks probably need a little tweaking to continue working"

If somebody knows what exactly has changed, I would be more than happy to try
modifying my driver disks.. 

As said, I'm able to create 100% working custom/selfmade driver disks for
RHEL4.. but same kind of driver disks don't work anymore with FC5/FC6..

Installer/Anaconda doesn't even try loading the module from the driver disk.. it
just somehow discards the whole driver disk in the first place.
Comment 15 Sarah Prelutsky 2006-09-13 14:47:31 EDT
We have had no luck getting DDs to work with Fedora Core 5. Fortunatly if you
are installing via PXE you can recompile the initrd it loads with with the
driver disk and will work just fine. So something is obviously wrong with how
its using the DD cause when you recomile the initrd with the SAME driver disk
that refuses to work everything works as expected and the machine installs
without the need of any other driver disks.
Comment 16 Pasi Karkkainen 2006-09-13 15:58:12 EDT
More comments from Jeremy Katz: 

"the thing that sticks out is that pcitable isn't used anymore (I think the code
has been nuked from kudzu)"

"instead depending on modules.pcimap"

"as it was in rhel4?  I don't _think_ it's changed.  you can compare to the
generated modules.pcimap in /lib/modules/$(uname -r)"

Comment 17 Pasi Karkkainen 2006-09-13 17:52:24 EDT
With help from Jeremy Katz I was able to build working driver disk for FC6 test2!

It seems "modules.alias" is now required file on driver disk.. and the driver
disk won't be loaded if that file is missing. 

Also "pcitable" is still required, but probably not used at all.. 

More info later!
Comment 18 Jeremy Katz 2006-09-14 15:04:04 EDT
Okay, I've updated anaconda in CVS to ensure that the files that we really
require now are there. 

These are: rhdd, modules.cgz, modinfo, modules.alias and modules.dep

If one of these files is missing, you'll get an error message stating that your
driver disk is an invalid format (and the exact missing file gets logged to tty3)

Hopefully this will help make the failure case a bit more obvious.  Thanks a lot
to Pasi for helping to track this down
Comment 19 ravi anand 2006-09-15 04:09:28 EDT
Jeremy,

So these changes will get folded in next beta release of RHEL 5 branch as well ?

Ravi
Comment 20 Pasi Karkkainen 2006-09-15 04:18:08 EDT
Thanks Jeremy!

I guess this fixed version will be in the final FC6 release?
Comment 21 Jeremy Katz 2006-09-15 05:58:08 EDT
Yes and yes

Note You need to log in before you can comment on or make changes to this bug.