Bug 1959014 - pyproj: FTBFS in Fedora rawhide (maybe since proj 8.0.1)
Summary: pyproj: FTBFS in Fedora rawhide (maybe since proj 8.0.1)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pyproj
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jos de Kloe
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F35FTBFS PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-05-10 14:58 UTC by Miro Hrončok
Modified: 2021-05-11 06:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-11 06:04:58 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2021-05-10 14:58:37 UTC
Description of problem:
Package pyproj fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
3.0.1-2.fc35

Steps to Reproduce:
koji build --scratch f35 pyproj-3.0.1-2.fc35.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/pyproj

=================================== FAILURES ===================================
________________________________ test_osgb_1936 ________________________________
    def test_osgb_1936():
        crs = CRS("OSGB 1936 / British National Grid")
        param_dict = _to_dict(crs.coordinate_operation)
        expected_cf = {
            "semi_major_axis": crs.ellipsoid.semi_major_metre,
            "semi_minor_axis": crs.ellipsoid.semi_minor_metre,
            "inverse_flattening": crs.ellipsoid.inverse_flattening,
            "reference_ellipsoid_name": "Airy 1830",
            "longitude_of_prime_meridian": 0.0,
            "prime_meridian_name": "Greenwich",
            "geographic_crs_name": "OSGB 1936",
            "horizontal_datum_name": "OSGB 1936",
            "projected_crs_name": "OSGB 1936 / British National Grid",
            "grid_mapping_name": "transverse_mercator",
            "latitude_of_projection_origin": 49.0,
            "longitude_of_central_meridian": -2.0,
            "false_easting": 400000.0,
            "false_northing": -100000.0,
            "scale_factor_at_central_meridian": param_dict[
                "Scale factor at natural origin"
            ],
        }
        cf_dict = crs.to_cf()
        assert cf_dict.pop("crs_wkt").startswith("PROJCRS[")
>       assert cf_dict == expected_cf
E       AssertionError: assert {'false_easti...ercator', ...} == {'false_easti...ercator', ...}
E         Omitting 12 identical items, use -vv to show
E         Differing items:
E         {'projected_crs_name': 'OSGB36 / British National Grid'} != {'projected_crs_name': 'OSGB 1936 / British National Grid'}
E         {'horizontal_datum_name': 'Ordnance Survey of Great Britain 1936'} != {'horizontal_datum_name': 'OSGB 1936'}
E         {'geographic_crs_name': 'OSGB36'} != {'geographic_crs_name': 'OSGB 1936'}
E         Use -v to get the full diff
test/crs/test_crs_cf.py:870: AssertionError
------------------------------ Captured log call -------------------------------
DEBUG    pyproj:crs.py:965 PROJ_ERROR: proj_crs_get_sub_crs: Object is not a CompoundCRS
=============================== warnings summary ===============================
test/test_datadir.py::test_get_data_dir__from_user[str]
test/test_datadir.py::test_get_data_dir__from_user[Path]
test/test_datadir.py::test_append_data_dir__internal[str]
test/test_datadir.py::test_append_data_dir__internal[Path]
  /builddir/build/BUILDROOT/pyproj-3.0.1-2.fc35.x86_64/usr/lib64/python3.9/site-packages/pyproj/datadir.py:37: UserWarning: pyproj unable to set database path.
    _global_context_set_data_dir()
test/test_transformer.py::test_transformer_group__unavailable
test/test_transformer.py::test_transformer_group__network_disabled
test/test_transformer.py::test_transformer_group__download_grids__directory
  /builddir/build/BUILDROOT/pyproj-3.0.1-2.fc35.x86_64/usr/lib64/python3.9/site-packages/pyproj/transformer.py:81: UserWarning: Best transformation is not available due to missing Grid(short_name=us_noaa_alaska.tif, full_name=, package_name=, url=https://cdn.proj.org/us_noaa_alaska.tif, direct_download=True, open_license=True, available=False)
    super().__init__(
test/test_transformer.py::test_transformer_group__get_transform_crs
  /builddir/build/BUILDROOT/pyproj-3.0.1-2.fc35.x86_64/usr/lib64/python3.9/site-packages/pyproj/transformer.py:81: UserWarning: Best transformation is not available due to missing Grid(short_name=nl_nsgi_rdtrans2018.tif, full_name=, package_name=, url=https://cdn.proj.org/nl_nsgi_rdtrans2018.tif, direct_download=True, open_license=True, available=False)
    super().__init__(
-- Docs: https://docs.pytest.org/en/stable/warnings.html
=========================== short test summary info ============================
FAILED test/crs/test_crs_cf.py::test_osgb_1936 - AssertionError: assert {'fal...
= 1 failed, 702 passed, 1 skipped, 24 deselected, 8 warnings in 105.24s (0:01:45) =


Note You need to log in before you can comment on or make changes to this bug.