Bug 195906 - ypbind service fails to start and times-out with YPBINDPROC_DOMAIN: Domain not bound
Summary: ypbind service fails to start and times-out with YPBINDPROC_DOMAIN: Domain n...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: ypbind (Show other bugs)
(Show other bugs)
Version: 5
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-19 14:21 UTC by David W. Legg
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-22 12:35:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David W. Legg 2006-06-19 14:21:59 UTC
Description of problem:
NIS/yp service fails to start on boot-up on FC5 pentium lap-top with fully
updated FC5 (not with development or test packages, though, just released
updates.)  I'm not sure which package update broke yp, becasue the pm-suspend
and pm-hibernate work so well nowadays that I haven't rebooted for ages.
Nothing has changed on our yp server.

Version-Release number of selected component (if applicable):
ypbind-1.19-0.i386.rpm (but this has not changed recently)

How reproducible:
100%

Steps to Reproduce:
1. Boot machine
2. Attempts to start NIS
3. Says  YPBINDPROC_DOMAIN: Domain not bound lots of times then gives up
  
Actual results:
 YPBINDPROC_DOMAIN: Domain not bound error message

Expected results:
 Brief pause while NIS client registers with YP server.

Additional info:
This appears to be something that has broken in the last week's worth of FC5
updates.

/etc/yp.conf says: domain eng.pto.optronics.co.uk server <ip number>
(with the ip number filled in, obviously.)

/etc/sysconfig/network/network contains the domain name too.

None of this has changed.  Last week NIS was ok; this week: Broken.

Comment 1 Steve Dickson 2006-06-19 15:09:59 UTC
What is the output of 'domainname' ?

Comment 2 David W. Legg 2006-06-19 15:35:17 UTC
domainname returns the expected NIS domain = eng.pto.optronics.co.uk


Comment 3 Steve Dickson 2006-06-30 11:38:21 UTC
Is there anything in /var/log/messags what would give
a clue as to what broke? 

Comment 4 David W. Legg 2006-06-30 11:57:59 UTC
This problem has become unreproduceable since I changed the network cable on the
machine.  Has anyone else confirmed the problem?  If not, I suggest we close the
bugzilla report.

I'm rather surprised that a simple cable could cause such a behaviourally
complex problem.


Note You need to log in before you can comment on or make changes to this bug.