Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1959555 - pulp3: RPM include filter includes extra RPMs in the content view version
Summary: pulp3: RPM include filter includes extra RPMs in the content view version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Repositories
Version: 6.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: 6.10.0
Assignee: James Jeffers
QA Contact: Cole Higgins
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-11 18:55 UTC by Ian Ballou
Modified: 2021-11-16 14:11 UTC (History)
2 users (show)

Fixed In Version: tfm-rubygem-katello-4.1.1.17-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-16 14:10:56 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 33358 0 None None None 2021-08-27 19:51:23 UTC
Foreman Issue Tracker 33365 0 None None None 2021-08-27 19:51:09 UTC
Red Hat Product Errata RHSA-2021:4702 0 None None None 2021-11-16 14:11:11 UTC

Description Ian Ballou 2021-05-11 18:55:40 UTC
Description of problem:

After switching to Pulp 3, including only 'vim-minimal' RPMs from the 'Red Hat Enterprise Linux 8 for x86_64 - BaseOS RPMs 8' repository without dependency solving includes RPMs that are outside of the filter.

Version-Release number of selected component (if applicable):

satellite-6.9.1-1.el7sat.noarch

Pulp 3 versions:

pulp-2to3-migration (0.11.1)
pulp-certguard (1.0.3)
pulp-container (2.1.2)
pulp-file (1.3.0)
pulp-rpm (3.10.0)
pulpcore (3.7.6)

How reproducible:
100%.  Also reproducible on the latest Katello dev box.



Steps to Reproduce:
1. Sync 'Red Hat Enterprise Linux 8 for x86_64 - BaseOS RPMs 8'
2. Make a content view with the BaseOS repo and an RPM include filter that includes 'vim-minimal' with all architectures & versions
3. Publish the content view

Actual results:
Resulting content view has 17 packages instead of just the 4 vim-minimal packages.  Only has errata related to vim-minimal.

Expected results:
Resulting content view version has only vim-minimal package(s) and the related errata

Additional info:

Comment 1 James Jeffers 2021-08-27 19:51:03 UTC
Connecting redmine issue https://projects.theforeman.org/issues/33365 from this bug

Comment 2 James Jeffers 2021-08-27 19:51:22 UTC
Connecting redmine issue https://projects.theforeman.org/issues/33358 from this bug

Comment 3 Bryan Kearney 2021-09-02 20:04:54 UTC
Moving this bug to POST for triage into Satellite since the upstream issue https://projects.theforeman.org/issues/33358 has been resolved.

Comment 10 errata-xmlrpc 2021-11-16 14:10:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: Satellite 6.10 Release), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2021:4702


Note You need to log in before you can comment on or make changes to this bug.