This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 195956 - print an error message when lock/unlock return an error
print an error message when lock/unlock return an error
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: dlm (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Teigland
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-19 17:13 EDT by David Teigland
Modified: 2010-01-04 14:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-04 14:56:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Teigland 2006-06-19 17:13:22 EDT
Description of problem:

dlm_lock() and dlm_unlock() occasionally return an error (EINVAL)
to gfs/lock_dlm which causes the machine to panic.  The problem
is that any number of conditions can lead to this and we have no
way of knowing which it was.  We would have a much better chance
of diagnosing and fixing problems if a message was printed for
each specific error condition.  This is something we've wanted
to do for a long time, but never gotten around to it.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Teigland 2006-06-22 10:24:51 EDT
CVSROOT:        /cvs/cluster
Module name:    cluster
Branch:         RHEL4
Changes by:     teigland@sourceware.org 2006-06-22 14:29:54

Modified files:
        dlm-kernel/src : locking.c

Log message:
        Add a log_error() for every abnormal error/exit condition in dlm_lock() 
        and dlm_unlock().  When gfs panics after it gets the error we can look  
        back and see what the cause was.

Note You need to log in before you can comment on or make changes to this bug.