Bug 1959598 - [RHEL 8.5] sosreport needs to collect data about conversions and upgrades
Summary: [RHEL 8.5] sosreport needs to collect data about conversions and upgrades
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: sos
Version: 8.5
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: beta
: ---
Assignee: Pavel Moravec
QA Contact: Miroslav Hradílek
URL:
Whiteboard:
Depends On:
Blocks: 1959779 1959781 1959782 1959783 1985551 1985552 1992957 1992958
TreeView+ depends on / blocked
 
Reported: 2021-05-11 21:08 UTC by Terry Bowling
Modified: 2021-11-10 07:44 UTC (History)
11 users (show)

Fixed In Version: sos-4.1-4.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1959779 1959781 1959782 1959783 1985551 1985552 1992957 1992958 (view as bug list)
Environment:
Last Closed: 2021-11-09 19:36:31 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github sosreport sos pull 2627 0 None open [MigrationResults] collect info about conversions and upgrades 2021-07-26 11:36:19 UTC
Red Hat Product Errata RHEA-2021:4388 0 None None None 2021-11-09 19:36:56 UTC

Description Terry Bowling 2021-05-11 21:08:42 UTC
Description of problem:

RHEL has multiple tools for performing in place upgrades, as well as conversions from RHEL derivitive distributions.  We need to ensure that for troubleshooting purposes, sosreport is collecting the log files from this tooling, as well as the status file from /etc/, as defined in https://issues.redhat.com/browse/RHELBU-1336

Version-Release number of selected component (if applicable):

Ideally, this change would be backported to sosreport in the following releases:

9.0
8.2, 8.3, 8.4, 8.5
7.9
6.10

Comment 1 Jake Hunsaker 2021-05-11 21:35:54 UTC
Am I reading that correctly that the status files will be named `/etc/convert2rhel` and `/etc/leapp`? Or will it be something like `/etc/convert2rhel-$date` or similar?

Is there a full list of convert2rhel/leapp env vars that should be captured as well?

Comment 2 Jose Castillo 2021-05-12 07:34:17 UTC
Also, I can see that in the documentation customers can specify an user and a password:

# convert2rhel --username <username> --password <password> --pool <pool_id>

Does this get recorded in the logs we already capture:

            "/var/log/convert2rhel/convert2rhel.log",
            "/var/log/convert2rhel/rpm_va.log"

Or in the configuration files perhaps?

Comment 5 Michal Bocek 2021-07-23 18:49:42 UTC
The file to newly collect is /etc/migration-results.

When to collect: when at least one of the packages is installed (convert2rhel, leapp, leapp-repository).

There are already these two plugins:
- leapp: https://github.com/sosreport/sos/pull/1753/files
- convert2rhel: https://github.com/sosreport/sos/pull/1915/files
It seems to me these two could be extended to gather this new file.

To Jose from #c2:
> Also, I can see that in the documentation customers can specify an user and a password:
> # convert2rhel --username <username> --password <password> --pool <pool_id>
> Does this get recorded in the logs we already capture:
>            "/var/log/convert2rhel/convert2rhel.log",
>            "/var/log/convert2rhel/rpm_va.log"

The username gets recorded in the /var/log/convert2rhel/convert2rhel.log, but not the password. Just asterisks are recorded instead.
One of the information recorded in the /etc/migration-results will be the command that has been executed but we'll hide the password there as well, e.g. "convert2rhel --username name --password *** --pool 123".

We'll need this sos change for
7.9
8.2 EUS (only leapp/leapp-repository)
8.4
8.5
9.0 (only leapp/leapp-repository)
CentOS Stream 9 (only leapp/leapp-repository)

I'll make sure BZs for the other RHELs are created or updated.

Comment 6 Michal Bocek 2021-07-23 19:10:28 UTC
To Jake from #c1:
No need to capture env vars. The env vars we need to know about are going to be recorded in the /etc/migration-results itself.

Comment 7 Pavel Moravec 2021-07-26 11:36:20 UTC
hOK, after a chat with mbocek, the final agreement is:

On Red Hat distros (or at least on RHEL+CentOS), we should newly collect /etc/migration-results file. Independently on leapp / convert2rhel packages, hence in a new plugin.

Upstream https://github.com/sosreport/sos/pull/2627 raised, we will try to squeeze to 8.5/9.0beta at "five after 12" time (as it is a tiny change with no regression).

Comment 9 Pavel Moravec 2021-08-12 06:39:04 UTC
Granting zstream+ for 8.2.z and 8.4.z, as agreed on Tue CEE supportability SST call. This is required to properly clone the BZ.

Comment 14 errata-xmlrpc 2021-11-09 19:36:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (sos bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2021:4388


Note You need to log in before you can comment on or make changes to this bug.