Bug 195964 - mkinitrd should not insist on module tree being present
mkinitrd should not insist on module tree being present
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-19 19:55 EDT by Steffen Kluge
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-13 11:13:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steffen Kluge 2006-06-19 19:55:36 EDT
Description of problem:

Trying to build an initrd for a monolithic kernel fails because mkinitrd expects
a module tree for a the kernel in /lib/modules and a modules.dep file in there.

Version-Release number of selected component (if applicable):

mkinitrd-5.0.32-1

How reproducible:

Steps to Reproduce:
1. Build a custom kernel without module support
2. Try to make an initrd for it using mkinitrd
3.
  
Actual results:

mkinitrd stops with message:
No modules available for kernel "xyz"

Expected results:

An initrd matching the monolithic kernel should be built. There should be a
command line switch to mkinitrd that causes the module tree check to be skipped.

Additional info:

An initrd for a monolithic kernels is required when using a software RAID or LVM
device for the root filesystem. A workaround to the issue is creating the
expected directory under /lib/modules, and in there an empty modules.dep file.
Comment 1 Peter Jones 2006-07-13 11:13:29 EDT
We don't support monolithic kernels.

Note You need to log in before you can comment on or make changes to this bug.