Bug 196001 - update-gtk-immodules called with wrong triplet from scim-libs scripts
update-gtk-immodules called with wrong triplet from scim-libs scripts
Status: CLOSED DUPLICATE of bug 195763
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Depends On:
  Show dependency treegraph
Reported: 2006-06-20 05:46 EDT by Kir Kolyshkin
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-06-20 07:29:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kir Kolyshkin 2006-06-20 05:46:14 EDT
scim-libs scripts gives the following error while both installing and
uninstalling (showing uninstall case here:

# rpm -e scim-libs
/usr/bin/update-gtk-immodules: line 27:
/etc/gtk-2.0/i386-redhat-linux-gnu/gtk.immodules: No such file or directory
error: %postun(scim-libs-1.4.4-9.4.fc5.i386) scriptlet failed, exit status 1

Apparently, the right directory is i686-redhat-linux-gnu not i386...:
$ rpm -qf /etc/gtk-2.0/i686-redhat-linux-gnu/

The problem is update-gtk-immodules in scim-libs scripts is called with the
wrong argument

$ rpm -q --scripts scim-libs-1.4.4-9.4.fc5
postinstall scriptlet (using /bin/sh):
/usr/bin/update-gtk-immodules i386-redhat-linux-gnu
postuninstall scriptlet (using /bin/sh):
/usr/bin/update-gtk-immodules i386-redhat-linux-gnu

I found another package which contains those calls with the right triplet:
$ rpm -q --scripts gtk2-2.8.19-2
postinstall scriptlet (using /bin/sh):
/usr/bin/update-gdk-pixbuf-loaders i686-redhat-linux-gnu
/usr/bin/update-gtk-immodules i686-redhat-linux-gnu
$ rpm -q --qf '%{name}.%{arch}\n' gtk2

$ rpm -q scim-libs gtk2 fedora-release

PS please note there is no scim-libs component in this bugzilla for FC5.
Comment 1 Jens Petersen 2006-06-20 07:29:00 EDT

*** This bug has been marked as a duplicate of 195763 ***

Note You need to log in before you can comment on or make changes to this bug.