Bug 196028 - shell tests do not always work properly on automounted directories
shell tests do not always work properly on automounted directories
Status: CLOSED DUPLICATE of bug 142856
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-20 10:32 EDT by Tim Kelley
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-05 17:06:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Kelley 2006-06-20 10:32:54 EDT
Description of problem:      
run-parts fails (very often) on autofs controlled directories      
      
Version-Release number of selected component (if applicable):      
4.1.3-154  
      
How reproducible:      
90%      
      
Steps to Reproduce:      
1. add autofs controlled directory to /etc/crontab      
  e.g.    
"01 * * * * root run-parts /usr/local/etc/cron.hourly"    
    
2. Let it go for a while and watch run-parts fail.  the [! -d $1 ] test 
in /usr/bin/run-parts does not always succeed.  It seems to succeed 100% in 
the shell interactively.  It is very inconsistent. 
      
        
Actual results:      
    
run-parts fails; the test to see if $1 is a directory fails, where $1 is an 
automounted directory. 
      
Expected results:      
    
run-parts would work    
      
Additional info:      
autofs options are --ghost and --timeout=60. this sort of thing seems to fail   
only when run from cron.  Just doing "test -d /foo/bar" interactively seems to   
work all the time (where bar is automounted).
Comment 1 Jeffrey Moyer 2006-06-20 11:23:19 EDT
I can't reproduce this problem.  Can you at least try U7 kernel and autofs
packges?  There have been fixes to expire/mount races when ghosting is involved,
so perhaps you are running into that.

Thanks.
Comment 2 Tim Kelley 2006-06-20 12:36:27 EDT
will try this as soon as possible ... can you keep the bug open for a while?  
This problem is very inconsistent ...
Comment 3 Tim Kelley 2006-06-20 12:37:15 EDT
will try this as soon as possible ... can you keep the bug open for a while?  
This problem is very inconsistent ...
Comment 4 Jeffrey Moyer 2006-06-20 12:51:19 EDT
Yes, of course.  But I am still awaiting information from you, so I've changed
the state appropriately.
Comment 5 Tim Kelley 2006-07-05 17:02:08 EDT
Jeffrey, 
 
Updating seems to have resolved the problem, thanks. 
Comment 6 Jeffrey Moyer 2006-07-05 17:06:19 EDT
Great!

*** This bug has been marked as a duplicate of 142856 ***

Note You need to log in before you can comment on or make changes to this bug.