Bug 196035 - openoffice crashed while idle and produced this report
openoffice crashed while idle and produced this report
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-20 11:36 EDT by Scott R. Godin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-04 10:41:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott R. Godin 2006-06-20 11:36:40 EDT
Description of problem: (summary text will need updating whem problem is better 
determined)

openoffice writer crashed while idle in the background.

Version-Release number of selected component (if applicable):
openoffice.org-core-2.0.2-5.12.2
openoffice.org-writer-2.0.2-5.12.2

How reproducible: 

unknown. 

OOo crahsed while idle in the background, while I was away from the keys, and 
xscreensaver was running. Three MS-Word doc files were open at the time, each 
only consisting of 1 page length, plain text/uncomplicated documents.


Steps to Reproduce:
1.
2.
3.
  
Actual results: see below


Expected results: this is rather obvious, right? 


Additional info:
bug report text produced by crash dialog follows:

Video Driver is probably: nvidia (yes, livna's kmod-nvidia package. kmod-nvidia-
1.0.8762-2.2.6.16_1.2133_FC5 xorg-x11-drv-nvidia-1.0.8762-3.lvn5)
Desktop is: not GNOME (was in fact xfce (current with yum as of this date)
libgcj version is: libgcj-4.1.1-1.fc5
kernel is: Linux 2.6.16-1.2133_FC5 #1 Tue Jun 6 00:52:14 EDT 2006 i686 athlon i
386
OpenOffice.org core rpm version is: openoffice.org-core-2.0.2-5.12.2
accessibility is: false
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   permissive
Mode from config file:          permissive
Policy version:                 20
Policy from config file:        targeted
...end sestatus details ...
0x527b680: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e680
0x527bec0: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1eec0
0x472420:  + 0x420 (__kernel_sigreturn + 0x0)
0x760dd14: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x168d14
0x7b06941: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x661941
0x722a89d: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x4289d
0x722a8e1: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x428e1
0x722b905: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x43905
0x730f2d4: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x1272d4
0x63c2c5f: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c1c5f
0x63c4ca0: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c3ca0
0x635ff9d: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x15ef9d
0x63646c7: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1636c7 
(SfxBaseModel::Notify(SfxBroadcaster&, SfxHint const&) + 0x391)
0x5abcf79: /usr/lib/openoffice.org2.0/program/libsvl680li.so + 0x87f79 
(SfxBroadcaster::Broadcast(SfxHint const&) + 0x43)
0x62b4e31: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xb3e31
0x62b4e70: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xb3e70
0x5783e46: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x82e46
0x578f80e: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e80e (Timer::
Timeout() + 0x10)
0x578f9a8: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e9a8
0x3759527: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3c527
0x3759360: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3c360 
(SalData::Timeout() const + 0x24)
0xe12b8b: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x14b8b
0x11cc876: /usr/lib/libglib-2.0.so.0 + 0x25876
0x11cc15d: /usr/lib/libglib-2.0.so.0 + 0x2515d (g_main_context_dispatch + 0x16d)
0x11cf3ef: /usr/lib/libglib-2.0.so.0 + 0x283ef
0x11cf955: /usr/lib/libglib-2.0.so.0 + 0x28955 (g_main_context_iteration + 0x65)
0xe12bf3: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x14bf3
0x3760315: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x43315 
(X11SalInstance::Yield(unsigned char) + 0x27)
0x578b3b6: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8a3b6 
(Application::Yield() + 0x48)
0x578b43a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8a43a 
(Application::Execute() + 0x26)
0x744a0bb: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x280bb (desktop::
Desktop::Main() + 0x15af)
0x578f4a6: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e4a6
0x578f559: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e559 (SVMain
() + 0x2b)
0x7442bf3: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x20bf3 (sal_main 
+ 0x57)
0x7442c3f: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x20c3f (main + 0x
27)
0x116724: /lib/libc.so.6 + 0x15724 (__libc_start_main + 0xdc)
0x80484d1: /usr/lib/openoffice.org2.0/program/swriter.bin + 0x4d1
Comment 1 Scott R. Godin 2006-06-20 11:48:59 EDT
at this point oowriter fails to start EVERY time. I am no longer able to edit 
or view these documents, as I get the following error with each attempt:

/usr/lib/openoffice.org2.0/program/soffice: line 151: 18716 Illegal 
instruction     "$sd_prog/$sd_binary" "$@"

The first time I attempted to open the documents, oowriter asked if I wanted to 
'start recovery'. Quite naturally, I clicked yes. This failed with the above 
error message, which is ALL I get at this point. I can't work on the client's 
files, and this is actually an urgent update.  I need help NOW as to what to do 
to stop this error from continuing so that I can open these files and adapt 
their contents for the client's website. COMPLETE SHOWSTOPPER and I have a 
PAYING CLIENT waiting for me to finish the job. HELP!!

I'll be happy to attach the files if anyone needs to see them. 
Comment 2 Scott R. Godin 2006-06-21 08:37:21 EDT
I've since deleted the ~/.openoffice.org2.0/ directory and at least got the app 
running again, so the urgency is over with. I'd still really like to know what 
happened though. moved severity back to normal. 
Comment 3 Caolan McNamara 2006-06-26 05:43:43 EDT
There *was* a gcc bug (bitfield accesses) which caused a crash on idling (well
on screen refreshes) but that was solved (worked around) for fc5 IIRC.

Not sure yet, crash when idles are hard to identify.
Comment 4 Caolan McNamara 2006-07-03 07:40:48 EDT
crash mapped back to debuginfo is...

1        50%    /usr/src/debug/OOB680_m5/sal/osl/unx/signal.c:484       ReportCrash
2        50%    /usr/src/debug/OOB680_m5/sal/osl/unx/signal.c:811      
SignalHandlerFunction
3         0%    0x472420:  + 0x420 (__kernel_sigreturn + 0x0)
4        50%    /usr/src/debug/OOB680_m5/sw/source/core/edit/edattr.cxx:186    
SwEditShell::GetAttr(SfxItemSet&) const
5        50%    /usr/src/debug/OOB680_m5/sw/source/ui/utlui/glbltree.cxx:1426  
SwGlobalTree::Update(unsigned char)
6        50%   
/usr/src/debug/OOB680_m5/framework/source/services/documentproperties.cxx:2048 
framework::DocumentProperties::impl_writeToStream(SvStream&, rtl::OUString
const&, unsigned short const&)
7        50%   
/usr/src/debug/OOB680_m5/framework/source/services/documentproperties.cxx:2054 
framework::DocumentProperties::impl_writeToStream(SvStream&, rtl::OUString
const&, unsigned short const&)
8        50%   
/usr/src/debug/OOB680_m5/framework/source/services/documentproperties.cxx:405  
__static_initialization_and_destruction_0
9        50%   
/usr/src/debug/OOB680_m5/framework/source/uiconfiguration/moduleimagemanager.cxx:523
   framework::ModuleImageManager::implts_getUserImageList(framework::ImageType)
10       75%   
/usr/src/debug/OOB680_m5/sfx2/source/notify/eventsupplier.cxx:880      
SfxGlobalEvents_Impl::implts_notifyListener(com::sun::star::document::EventObject
const&)
11       75%   
/usr/src/debug/OOB680_m5/sfx2/source/notify/eventsupplier.cxx:698      
SfxGlobalEvents_Impl::notifyEvent(com::sun::star::document::EventObject const&)
12       75%    /usr/src/debug/OOB680_m5/sfx2/source/doc/sfxbasemodel.cxx:3428 
SfxBaseModel::postEvent_Impl(unsigned short)
13      100%    /usr/src/debug/OOB680_m5/sfx2/source/doc/sfxbasemodel.cxx:3108 
SfxBaseModel::Notify(SfxBroadcaster&, SfxHint const&)
14      100%    /usr/src/debug/OOB680_m5/svtools/source/notify/brdcst.cxx:79   
SfxBroadcaster::Broadcast(SfxHint const&)
15       75%    /usr/src/debug/OOB680_m5/sfx2/source/appl/appcfg.cxx:224       
SfxEventAsyncer_Impl::TimerHdl(Timer*)
16       75%    /usr/src/debug/OOB680_m5/sfx2/source/appl/appcfg.cxx:212       
SfxEventAsyncer_Impl::LinkStubTimerHdl(void*, void*)
17       75%   
/usr/src/debug/OOB680_m5/solver/680/unxlngi6.pro/inc/tools/link.hxx:154
Link::Call(void*) const
18      100%    /usr/src/debug/OOB680_m5/vcl/source/app/timer.cxx:281  
Timer::Timeout()
19       75%    /usr/src/debug/OOB680_m5/vcl/source/app/timer.cxx:170  
ImplTimerCallbackProc()
20       75%    ../../../inc/saltimer.hxx:81    SalTimer::CallCallback()
21      100%    /usr/src/debug/OOB680_m5/vcl/unx/source/app/saltimer.cxx:66    
SalData::Timeout() const
22       50%    /usr/src/debug/OOB680_m5/vcl/unx/gtk/app/gtkdata.cxx:585       
GtkXLib::timeoutFn(void*)
23       50%    0x11cc876: /usr/lib/libglib-2.0.so.0 + 0x25876
24       50%    0x11cc15d: /usr/lib/libglib-2.0.so.0 + 0x2515d
(g_main_context_dispatch + 0x16d)
25       50%    0x11cf3ef: /usr/lib/libglib-2.0.so.0 + 0x283ef
26       50%    0x11cf955: /usr/lib/libglib-2.0.so.0 + 0x28955
(g_main_context_iteration + 0x65)
27       50%    /usr/src/debug/OOB680_m5/vcl/unx/gtk/app/gtkdata.cxx:707       
GtkXLib::Yield(unsigned char)
28      100%    /usr/src/debug/OOB680_m5/vcl/unx/source/app/salinst.cxx:290    
X11SalInstance::Yield(unsigned char)
29      100%    /usr/src/debug/OOB680_m5/vcl/source/app/svapp.cxx:540  
Application::Yield()
30      100%    /usr/src/debug/OOB680_m5/vcl/source/app/svapp.cxx:500  
Application::Execute()
31      100%    /usr/src/debug/OOB680_m5/desktop/source/app/app.cxx:1696       
desktop::Desktop::Main()
32       75%    /usr/src/debug/OOB680_m5/vcl/source/app/svmain.cxx:242  ImplSVMain()
33      100%    /usr/src/debug/OOB680_m5/vcl/source/app/svmain.cxx:273  SVMain()
34      100%    /usr/src/debug/OOB680_m5/desktop/source/app/main.cxx:77 sal_main
35      100%    /usr/src/debug/OOB680_m5/desktop/source/app/main.cxx:71 main
36       50%    0x116724: /lib/libc.so.6 + 0x15724 (__libc_start_main + 0xdc)
37       50%    ??:0    ??
Comment 5 Caolan McNamara 2006-09-04 10:41:05 EDT
upstream tells me they saw a few of these and addressed the symptons for 2.0.4,
which we're including in FC-6
Comment 6 Scott R. Godin 2006-09-04 13:23:16 EDT
any chance this will be additionally released as an FC5 update after QA ?

Note You need to log in before you can comment on or make changes to this bug.