Bug 1960468 - SELinux is preventing /usr/lib/systemd/systemd-timesyncd from 'watch' accesses on the directory /run/dbus.
Summary: SELinux is preventing /usr/lib/systemd/systemd-timesyncd from 'watch' accesse...
Keywords:
Status: CLOSED DUPLICATE of bug 1965720
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 34
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:23fc93b626ebb291822ac9401e0...
: 1972263 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-14 00:14 UTC by John Apple II
Modified: 2021-06-15 14:46 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-15 14:46:08 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description John Apple II 2021-05-14 00:14:07 UTC
Description of problem:
Happened on system startup after upgrading to Fedora 34
SELinux is preventing /usr/lib/systemd/systemd-timesyncd from 'watch' accesses on the directory /run/dbus.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that systemd-timesyncd should be allowed watch access on the dbus directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'systemd-timesyn' --raw | audit2allow -M my-systemdtimesyn
# semodule -X 300 -i my-systemdtimesyn.pp

Additional Information:
Source Context                system_u:system_r:systemd_timedated_t:s0
Target Context                system_u:object_r:system_dbusd_var_run_t:s0
Target Objects                /run/dbus [ dir ]
Source                        systemd-timesyn
Source Path                   /usr/lib/systemd/systemd-timesyncd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           systemd-udev-248.2-1.fc34.x86_64
Target RPM Packages           dbus-daemon-1.12.20-3.fc34.x86_64
SELinux Policy RPM            selinux-policy-targeted-34.6-1.fc34.noarch
Local Policy RPM              selinux-policy-targeted-34.6-1.fc34.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.11.19-300.fc34.x86_64 #1 SMP Fri
                              May 7 14:17:15 UTC 2021 x86_64 x86_64
Alert Count                   2
First Seen                    2021-05-14 09:03:28 AEST
Last Seen                     2021-05-14 10:00:34 AEST
Local ID                      60f9c35a-d2ff-49ec-998d-660fd86e04f9

Raw Audit Messages
type=AVC msg=audit(1620950434.649:149): avc:  denied  { watch } for  pid=4020 comm="systemd-timesyn" path="/run/dbus" dev="tmpfs" ino=2261 scontext=system_u:system_r:systemd_timedated_t:s0 tcontext=system_u:object_r:system_dbusd_var_run_t:s0 tclass=dir permissive=0


type=SYSCALL msg=audit(1620950434.649:149): arch=x86_64 syscall=inotify_add_watch success=no exit=EACCES a0=b a1=56235fab0aa0 a2=2000d84 a3=1000 items=1 ppid=1 pid=4020 auid=4294967295 uid=995 gid=991 euid=995 suid=995 fsuid=995 egid=991 sgid=991 fsgid=991 tty=(none) ses=4294967295 comm=systemd-timesyn exe=/usr/lib/systemd/systemd-timesyncd subj=system_u:system_r:systemd_timedated_t:s0 key=(null)

type=CWD msg=audit(1620950434.649:149): cwd=/

type=PATH msg=audit(1620950434.649:149): item=0 name=/run/dbus inode=2261 dev=00:1a mode=040755 ouid=0 ogid=0 rdev=00:00 obj=system_u:object_r:system_dbusd_var_run_t:s0 nametype=NORMAL cap_fp=0 cap_fi=0 cap_fe=0 cap_fver=0 cap_frootid=0

Hash: systemd-timesyn,systemd_timedated_t,system_dbusd_var_run_t,dir,watch

Version-Release number of selected component:
selinux-policy-targeted-34.6-1.fc34.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.14.0
hashmarkername: setroubleshoot
kernel:         5.11.19-300.fc34.x86_64
type:           libreport

Comment 1 Christian Kujau 2021-06-06 22:36:18 UTC
duplicate of bug 1965720 ...?

Comment 2 valsu 2021-06-15 14:27:39 UTC
*** Bug 1972263 has been marked as a duplicate of this bug. ***

Comment 3 Zdenek Pytela 2021-06-15 14:46:08 UTC

*** This bug has been marked as a duplicate of bug 1965720 ***


Note You need to log in before you can comment on or make changes to this bug.