Bug 196100 - editing prelink.conf should not be necessary
editing prelink.conf should not be necessary
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: prelink (Show other bugs)
4.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-20 20:56 EDT by John Newbigin
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-23 05:17:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Newbigin 2006-06-20 20:56:39 EDT
Description of problem:
If a specific file needs to be excluded from prelinking, the prelink.conf file
must be edited.  Adding entries is easy enough but removing them is a PITA.

prelink should include the files in /etc/prelink.d/* and then the required
prelink config can be packaged in the rpm

Version-Release number of selected component (if applicable):
prelink-0.3.3-0.EL4

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jakub Jelinek 2006-06-21 02:58:45 EDT
Can you explain what exactly you need to edit and why?
Comment 2 John Newbigin 2006-06-21 19:15:44 EDT
McAfee command line scanner (uvscan) does not like being prelinked.  It assumes
that if it has been altered then it is the work of a virus.  The output from
uvscan is:
The program has been altered; please replace it with a good copy.

I have to add the following lines to /etc/prelink.conf to prevent the problem:
-b /usr/bin/uvscan
-b /usr/lib/liblnxfv.so.4

It seems reasonable that this config belongs to the uvscan package.

There are other entries in the default /etc/prelink.conf file which look like
they should come from certain packages.  At least xfig, LessTif and ftp have
per-package config entries which from what I can tell come configured in the
prelink package.
Comment 3 Jakub Jelinek 2006-06-23 05:17:15 EDT
uvscan should be fixed to take prelink into account, rather than trying such
workarounds.
xfig/LessTif/ftp related paths aren't in prelink.conf because those packages
would require it, but in order to prune deep directory trees with many clearly
non-ELF files in them from prelink searches.

Note You need to log in before you can comment on or make changes to this bug.