Bug 196104 - mkinitrd network code doesn't work for drivers without modaliases
mkinitrd network code doesn't work for drivers without modaliases
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-06-20 23:00 EDT by Jeremy Katz
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.47-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-13 13:12:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2006-06-20 23:00:02 EDT
The code in mkinitrd for finding net devices won't work for drivers which don't
have modaliases (aka Xen, and probably also some of the wacky platform net
devices too).  

I'll probably put in a hack for now for Xen, but we probably want a better fix
for fc6 final
Comment 1 Bill Nottingham 2006-06-28 23:49:04 EDT
Run ethtool -i <interface> and awk out the 'driver' field? (and beat drivers
that don't support that...)
Comment 2 Jeremy Katz 2006-06-29 11:02:03 EDT
Sounds sane... we could actually probably even do a combination of the two.  Try
the modalias first (because that will better handle if a driver changes names
from one kernel to another) and if that fails go for ethtool ops.
Comment 3 Bill Nottingham 2006-06-29 14:53:00 EDT
Added in CVS. Not built.

Note You need to log in before you can comment on or make changes to this bug.