Bug 19611 - I cannot change my password either using passwd or linuxconf
I cannot change my password either using passwd or linuxconf
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: passwd (Show other bugs)
7.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Jindrich Novy
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-23 11:25 EDT by chryssisg
Modified: 2013-07-02 18:54 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-06 10:02:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description chryssisg 2000-10-23 11:25:42 EDT
I have recently upgraded my linux RH 6.0 into RH 7.0.
Since then, I am not able to change my password, either
using passwd or linuxconf.
When I use passwd, I get the message:
"passwd: Authentication token manipulation error"
 (even when I am loged in as the root) 

When I use linuxconf, I get the message
"unknown error - password not changed"
Comment 1 Need Real Name 2000-10-24 13:04:11 EDT
I have also got the same error on my machines that were once RedHat 5.2 and have
upgraded via 6.0, 6.1, 6.2 and 7.0.  I do not find this error on machines that
have only
had 6.2 and 7.0 installed.   Also error only happened when I upgraded to 7.0.  
Jay Baltisberger
jhb@chemistry.berea.edu
Comment 2 Nalin Dahyabhai 2000-10-24 14:54:38 EDT
Are you using shadow passwords?  I believe this is related to an upgrade
situation where the system did not previously have shadow passwords enabled. 
You should be able to clear this up by running authconfig and toggling shadow
passwords off.
Comment 3 chryssisg 2000-10-24 15:29:47 EDT
Could you please tell me where the authconfig file
is located, because I wasn't able to find it and run it.

Comment 4 chryssisg 2000-10-24 15:44:40 EDT
Please disregard my previous email.
I was able to find and run the file.
I have disabled the shadow passwords and
the problem has been solved.

Thanks,
Chryssis Georgiou

Comment 5 Need Real Name 2000-10-24 17:25:21 EDT
It appears you can also turn them back on afterwards and the password
stuff is fully back to normal.
Comment 6 Gabriel Schulhof 2001-03-12 03:06:01 EST
I'm running RH70 (clean install) with PAM 0.72-37.  I have only MD5 and Shadow
turned on.  I can change the root password effortlessly, but for any given
regular user, with MD5 and Shadow off, I get this:

Changing password for nix
(current) UNIX password: 
New UNIX password: 
Retype new UNIX password: 
passwd: Authentication token manipulation error

If I turn on MD5 and Shadow, I get this:

Changing password for nix
(current) UNIX password: 
passwd: Authentication token manipulation error

I don't understand why I'm getting this.
Any help would be appreciated.
Comment 7 Need Real Name 2001-10-12 15:02:19 EDT
You first need to run /usr/sbin/pwconv, to get the contents of 
your /etc/passwd file converted into your /etc/shadow file. You'll also want 
to run /usr/sbin/grpconv to convert /etc/group info.

For NIX, who says he's not using password shadowing, I'm not sure what's going 
on...

It's also not a bad idea to run /usr/sbin/pwck and /usr/sbin/grpck, which 
conduct sanity tests of your passwd and group files. Running the convert 
programs with bad data in these files can cause an endless loop.
Comment 8 Isaac 2002-03-07 16:40:33 EST
I had the same problem.  I believe it's caused by linuxconf, but I'm not sure.  
What happens is, somehow, the setuid is removed from /sbin/passwd.  If that's 
the case, su to root and execute <i>chmod 4775 /usr/bin/passwd<i> and problem 
is solved.  I noticed that linuxconf did the same thing to my /var/spool/mqueue 
directory.
Comment 9 Need Real Name 2002-08-02 15:59:48 EDT
I tried all of the above fixes with no success.

When I run passwd as any user including root it gives me:
passwd: Authentication token manipulation error

I turned off and on password shadowing.  I'm using MD5 pssswords.
The setuid flag is set on /usr/bin/passwd.

I'm running a fairly dirty install of RH7.3.  I had to reinstall the base kernel
packages at one point.  Which package is passwd in?

Thanks, 
pixie
Comment 10 Jindrich Novy 2004-09-06 10:02:58 EDT
I recommend you to install some recent version of passwd
(passwd-0.68). Maybe it will solve your problem. Because it is rather
old bug and we have no bugreports concerning the mentioned issue in
recent releases, I'll close this bug as WONTFIX.

Jindrich

Note You need to log in before you can comment on or make changes to this bug.