Bug 196137 - yum crash at "Parsing package install arguments"
yum crash at "Parsing package install arguments"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-21 09:28 EDT by Mike
Modified: 2014-01-21 17:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-07 06:09:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike 2006-06-21 09:28:42 EDT
Description of problem:

# yum install screen
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
core                                                                 [1/3]
core                      100% |=========================| 1.1 kB    00:00
updates                                                              [2/3]
updates                   100% |=========================|  951 B    00:00
extras                                                               [3/3]
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 767 kB    00:26
core      : ################################################## 2207/2207
Added 2207 new packages, deleted 0 old in 146.18 seconds
primary.xml.gz            100% |=========================| 461 kB    00:15
updates   : ################################################## 1356/1356
Added 1356 new packages, deleted 0 old in 122.23 seconds
primary.xml.gz            100% |=========================| 1.2 MB    00:43
extras    : ################################################## 3370/3370
Added 3370 new packages, deleted 0 old in 224.30 seconds
Parsing package install arguments
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 97, in main
    result, resultmsgs = do()
  File "/usr/share/yum-cli/cli.py", line 474, in doCommands
    return self.installPkgs()
  File "/usr/share/yum-cli/cli.py", line 930, in installPkgs
    self.install(po)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 1661, in install
    self.doUpdateSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 326, in
doUpdateSetup
    self.up.doUpdates()
  File "/usr/lib/python2.4/site-packages/rpmUtils/updates.py", line 248, in
doUpdates
    (new_e,new_v,new_r) = self.returnNewest(newpkgs[(n, a)])
  File "/usr/lib/python2.4/site-packages/rpmUtils/updates.py", line 87, in
returnNewest
    rc = rpmUtils.miscutils.compareEVR((e, v, r), (new_e, new_v, new_r))
  File "/usr/lib/python2.4/site-packages/rpmUtils/miscutils.py", line 47, in
compareEVR
    rc = rpm.labelCompare((e1, v1, r1), (e2, v2, r2))
TypeError: argument 2 must be impossible<bad format char>, not tuple

Version-Release number of selected component (if applicable):

yum-2.6.1-0.fc5
rpm-4.4.2-15.2
python-sqlite-1.1.7-1.2
python-elementtree-1.2.6-4.2.1
rpm-python-4.4.2-15.2
python-urlgrabber-2.9.8-2

Steps to Reproduce:

# yum clean all
# yum install screen
Comment 1 Jeremy Katz 2006-09-18 16:48:52 EDT
Does this still happen with what's currently in -updates?
Comment 2 Mike 2006-10-07 06:09:28 EDT
It was caused by broken hardware.

Note You need to log in before you can comment on or make changes to this bug.