Bug 196139 - Scribes editor fails on startup
Summary: Scribes editor fails on startup
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: scribes
Version: 5
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Gordon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-21 14:15 UTC by James Bannon
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2006-06-25 18:38:46 UTC


Attachments (Terms of Use)

Description James Bannon 2006-06-21 14:15:35 UTC
Description of problem: Scribes version 0.2.5-1.fc5 does not start from the
menu. When started from the command line givs the following error:

(scribes:30095): GtkSourceView-CRITICAL **: gtk_source_view_set_tabs_width:
assertion `width > 0' failed
Traceback (most recent call last):
  File "/usr/bin/scribes", line 98, in ?
    main(argv[1:])
  File "/usr/lib/python2.4/site-packages/Scribes/main.py", line 158, in main
    editor = launch_new_editor(uri_list, readonly)
  File "/usr/lib/python2.4/site-packages/Scribes/main.py", line 107, in
launch_new_editor
    editor = Editor()
  File "/usr/lib/python2.4/site-packages/Scribes/editor.py", line 205, in __init__
    text_view = create_text_view(self)
  File "/usr/lib/python2.4/site-packages/Scribes/textview.py", line 861, in
create_text_view
    foreground_color = process_color(editor.foreground_color)
  File "/usr/lib/python2.4/site-packages/Scribes/utility.py", line 137, in
process_color
    red = int(color[0])
IndexError: list index out of range

Version-Release number of selected component (if applicable): 0.2.5-1.fc5

How reproducible: Always.

Steps to Reproduce:
1. Normal system setup for Gnome and then a yum update.
2. Install scribes (either through yumex or yum install scribes)
3. Start scribes from the command line.
  
Actual results: Error message as above.

Expected results: Launch scribes properly.


Additional info: Is this an incompatibility with the latest versions of Python &
GTK+?

Comment 1 Peter Gordon 2006-06-24 20:24:16 UTC
Hmm. I don't think that this would be from an incompatibility with the new
Python and/or GTK+ stuff, as my up-to-date FC5 system does not receive this error.

What versions of Python, GTK+, and pygtk2 do you have? Also, does this error
occur for you if you revert to the previous version of Scribes (0.2.4.3-3)?

Comment 2 James Bannon 2006-06-24 23:35:57 UTC
Here is the output of rpm -q for the requested packages:

python-2.4.3-4.FC5
gtk2-2.8.19-2
pygtk2-2.8.6-0.fc5.1
scribes-0.2.5-1.fc5

I have rebuilt my machine and re-installed a fresh copy of scribes but it still
won't launch. This time I get the error messages:

Traceback (most recent call last):
  File "/usr/bin/scribes", line 98, in ?
    main(argv[1:])
  File "/usr/lib/python2.4/site-packages/Scribes/main.py", line 142, in main
    editor = launch_new_editor()
  File "/usr/lib/python2.4/site-packages/Scribes/main.py", line 106, in
launch_new_editor
    from editor import Editor
  File "/usr/lib/python2.4/site-packages/Scribes/editor.py", line 59, in ?
    from actions import create_actions
  File "/usr/lib/python2.4/site-packages/Scribes/actions.py", line 54, in ?
    from savechooser import show_save_dialog
  File "/usr/lib/python2.4/site-packages/Scribes/savechooser.py", line 48, in ?
    from encoding import create_encoding_box
  File "/usr/lib/python2.4/site-packages/Scribes/encoding.py", line 46, in ?
    from gconf import VALUE_STRING
ImportError: No module named gconf

This is different from before. I have gconf installed version 2.14.0-1. What
versions of the various packages is scribes looking for?

Comment 3 Peter Gordon 2006-06-25 00:55:07 UTC
That's progress, I think. :)

Does Scribes work again if you install the gnome-python2-gconf package?

Comment 4 James Bannon 2006-06-25 10:44:21 UTC
This time it worked. Kind of strange though since it worked before without this
hassle. Must just have been a glitch when yum was working out the dependencies.

Comment 5 Peter Gordon 2006-06-25 18:38:46 UTC
It seems that, since I already had this package installed, I did not realize
that it was a needed dependency for Scribes.

I've added this to 0.2.5-2, which should hit the mirrors shortly.

Thanks for your bug report!


Note You need to log in before you can comment on or make changes to this bug.