Bug 1961436 - Error creating VM: API version in the data does not match
Summary: Error creating VM: API version in the data does not match
Keywords:
Status: CLOSED DUPLICATE of bug 1958811
Alias: None
Product: Container Native Virtualization (CNV)
Classification: Red Hat
Component: User Experience
Version: 4.8.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Tal Nisan
QA Contact: Oded Ramraz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-17 23:08 UTC by Chandler Wilkerson
Modified: 2021-05-19 14:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-19 14:53:27 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of error (164.94 KB, image/png)
2021-05-17 23:08 UTC, Chandler Wilkerson
no flags Details

Description Chandler Wilkerson 2021-05-17 23:08:56 UTC
Created attachment 1784245 [details]
Screenshot of error

Description of problem:
Creating a Windows VM from Win 2k19 template, got Error creating virtual machine

the API version in the data (kubevirt.io/v1) does not match the expected API version (kubevirt.io/v1alpha3)



Version-Release number of selected component (if applicable):
4.8.0 from brew.redhat.io using HCO iib:75498

How reproducible:
Always?

Steps to Reproduce:
1. Create base image for win2k19 template
2. Instantiate template by creating VM in UI using wizard
3. Click create VM

Actual results:
Error as given above

Expected results:
VM creates


Additional info:

Comment 1 Chandler Wilkerson 2021-05-18 13:01:50 UTC
Problem seems to be limited to UI's own checks, I copied the yaml of the VM and was able to create it from CLI.

Comment 2 Chandler Wilkerson 2021-05-19 14:53:27 UTC

*** This bug has been marked as a duplicate of bug 1958811 ***


Note You need to log in before you can comment on or make changes to this bug.