Bug 196144 - RHN: RPM timestamps out of sync with ISO RPM timestamps
RHN: RPM timestamps out of sync with ISO RPM timestamps
Status: CLOSED WONTFIX
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Rel-Eng (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Todd Sanders
Vlady Zlatkin
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-21 11:16 EDT by Brian Long
Modified: 2007-04-18 13:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-22 16:29:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Long 2006-06-21 11:16:20 EDT
Description of problem:
The timestamps on the RPMs included in an ISO for a given update are different
than the same RPMs downloaded from RHN.  This breaks the ability to hardlink
common RPMs between the ISOs and updates downloaded straight from RHN.

For example, the timestamp of kernel-2.6.9-39.EL.i686.rpm on the RHEL 4 U4 beta
ISO is June 1 19:44.  The timestamp on the same RPM downloaded from RHN is June
12 09:39.  If I extract the U4 beta ISOs to a directory and I also have a
synchronization script that downloads all updates from RHN, I cannot hardlink
the common updates together because of the timestamp differences.  Please
consider updating the RHN publish process such that RPM timestamps are
maintained as the same timestamp as the ISO.
Comment 3 Brad Hinson 2006-08-22 16:29:36 EDT
RHN uses the timestamp internally for ensuring consistency between the 
content published by Red Hat and the RHN satellite. For this reason, we 
cannot guarantee that the timestamp in RHN is always the same as the one 
shipped on the ISO images.

Note You need to log in before you can comment on or make changes to this bug.