Bug 196149 - pmidi using native midi on em10k1 casue fatal exceptions, kernel BUG at include/linux/list.h:58!
pmidi using native midi on em10k1 casue fatal exceptions, kernel BUG at inclu...
Status: CLOSED DUPLICATE of bug 194597
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-21 11:57 EDT by Knut J BJuland
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-22 10:37:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmegs (24.79 KB, text/plain)
2006-06-21 13:56 EDT, Knut J BJuland
no flags Details
strace off pmidi run (23.91 KB, application/octet-stream)
2006-06-21 14:00 EDT, Knut J BJuland
no flags Details

  None (edit)
Description Knut J BJuland 2006-06-21 11:57:06 EDT
Description of problem:
Fatal exceptions when stoping pmidi or playing pmid through native midi in
emu10k1 alsa. Played while running in single mode without running xorg.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.17-1.2138_FC5 and kernel-2.6.17-1.2138_FC5

How reproducible: 
every time

Steps to Reproduce:
1./sbin/modprobe snd-emu10k1-synth
2./bin/asfxload *.sf2
3.pmidi -p 17.0 any.midi file
4. hit ctrl-c during playing a midi file  
Actual results:

EIP 8997234 snd_seq_delete_all_ports

Expected results:
should stop playing as white playmidia -a midfile

Additional info:
Comment 1 Knut J BJuland 2006-06-21 13:56:14 EDT
Created attachment 131304 [details]
dmegs

dmesg off non smp kernel i686
Comment 2 Knut J BJuland 2006-06-21 13:58:30 EDT
cat /proc/modules
snd_emu10k1_synth 7745 0 - Live 0xf8f19000
snd_emux_synth 35137 1 snd_emu10k1_synth, Live 0xf8f25000
snd_seq_virmidi 8001 1 snd_emux_synth, Live 0xf8c20000
snd_seq_midi_emul 6465 1 snd_emux_synth, Live 0xf8c1d000
video 16709 0 - Live 0xf8c24000
button 6993 0 - Live 0xf8bf4000
battery 10053 0 - Live 0xf8c19000
ac 5189 0 - Live 0xf8bf7000
lp 12937 0 - Live 0xf8bfa000
parport_pc 27237 1 - Live 0xf8c0c000
parport 37129 2 lp,parport_pc, Live 0xf8c01000
usblp 14401 0 - Live 0xf8b6b000
usb_storage 69153 0 - Live 0xf8b70000
ohci1394 34693 0 - Live 0xf8b51000
ieee1394 298649 1 ohci1394, Live 0xf8b92000
snd_emu10k1 117829 1 snd_emu10k1_synth, Live 0xf8a67000
snd_rawmidi 25665 2 snd_seq_virmidi,snd_emu10k1, Live 0xf8a4f000
snd_ac97_codec 92257 1 snd_emu10k1, Live 0xf8a86000
snd_ac97_bus 2625 1 snd_ac97_codec, Live 0xf899a000
snd_seq_dummy 4165 0 - Live 0xf8a03000
snd_seq_oss 32705 0 - Live 0xf8a46000
snd_seq_midi_event 7745 2 snd_seq_virmidi,snd_seq_oss, Live 0xf891d000
snd_seq 53553 8
snd_emux_synth,snd_seq_virmidi,snd_seq_midi_emul,snd_seq_dummy,snd_seq_oss,snd_seq_midi_event,
Live 0xf8a58000
snd_pcm_oss 40017 0 - Live 0xf8a23000
snd_mixer_oss 17729 1 snd_pcm_oss, Live 0xf89a4000
snd_pcm 83781 3 snd_emu10k1,snd_ac97_codec,snd_pcm_oss, Live 0xf8a30000
ehci_hcd 32461 0 - Live 0xf89f3000
uhci_hcd 23885 0 - Live 0xf89fc000
snd_seq_device 9037 7
snd_emu10k1_synth,snd_emux_synth,snd_emu10k1,snd_rawmidi,snd_seq_dummy,snd_seq_oss,snd_seq,
Live 0xf89a0000
floppy 58437 0 - Live 0xf8a06000
snd_timer 24517 3 snd_emu10k1,snd_seq,snd_pcm, Live 0xf89ec000
snd_page_alloc 10569 2 snd_emu10k1,snd_pcm, Live 0xf899c000
snd_util_mem 5569 2 snd_emux_synth,snd_emu10k1, Live 0xf891a000
snd_hwdep 10053 2 snd_emux_synth,snd_emu10k1, Live 0xf8993000
bt878 11529 0 - Live 0xf898f000
sg 34525 0 - Live 0xf8958000
snd 55237 13
snd_emux_synth,snd_seq_virmidi,snd_emu10k1,snd_rawmidi,snd_ac97_codec,snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_device,snd_timer,snd_hwdep,
Live 0xf8939000
tuner 50937 0 - Live 0xf894a000
tda9887 16209 0 - Live 0xf88ea000
msp3400 30177 0 - Live 0xf8909000
bttv 176181 1 bt878, Live 0xf8962000
video_buf 26181 1 bttv, Live 0xf8931000
ir_common 27461 1 bttv, Live 0xf8912000
compat_ioctl32 1601 1 bttv, Live 0xf8842000
i2c_algo_bit 8905 1 bttv, Live 0xf88ad000
v4l2_common 15553 3 tuner,msp3400,bttv, Live 0xf88e5000
btcx_risc 5193 1 bttv, Live 0xf88aa000
tveeprom 14673 1 bttv, Live 0xf88da000
videodev 9537 1 bttv, Live 0xf88d6000
soundcore 10016 1 snd, Live 0xf88d2000
tg3 99397 0 - Live 0xf88ef000
emu10k1_gp 4161 0 - Live 0xf88a7000
gameport 16201 2 emu10k1_gp, Live 0xf8832000
i2c_i801 8781 0 - Live 0xf8837000
i2c_core 22209 7 tuner,tda9887,msp3400,bttv,i2c_algo_bit,tveeprom,i2c_i801, Live
0xf88a0000
dm_snapshot 18285 0 - Live 0xf889a000
dm_zero 2241 0 - Live 0xf881c000
dm_mirror 22673 0 - Live 0xf883b000
dm_mod 59225 6 dm_snapshot,dm_zero,dm_mirror, Live 0xf888a000
ata_piix 11973 0 - Live 0xf882e000
ext3 129097 2 - Live 0xf88b1000
jbd 57813 1 ext3, Live 0xf887a000
ahci 17993 4 - Live 0xf8828000
libata 68049 2 ata_piix,ahci, Live 0xf8868000
sd_mod 20417 6 - Live 0xf8822000
scsi_mod 135657 5 usb_storage,sg,ahci,libata,sd_mod, Live 0xf8845000

The system is a Dell 8400 with audiogy2,  and geforce fx. But the nvidia driver
was not loaded.
Comment 3 Knut J BJuland 2006-06-21 14:00:02 EDT
Created attachment 131305 [details]
strace off pmidi run

strace off pmidi run
Comment 4 Knut J BJuland 2006-06-21 15:03:22 EDT
Jun 21 21:04:53 knutjorgen kernel: ------------[ cut here ]------------
Jun 21 21:04:53 knutjorgen kernel: kernel BUG at include/linux/list.h:58!
Jun 21 21:04:53 knutjorgen kernel: invalid opcode: 0000 [#1]
Jun 21 21:04:53 knutjorgen kernel: last sysfs file: /class/sound/midiC0D3/dev
Jun 21 21:04:53 knutjorgen kernel: Modules linked in: snd_seq_midi snd_rtctimer
snd_emu10k1_synth snd_emux_synth snd_seq_virmidi snd_seq_midi_emul ipv6 autofs4
hidp l2cap bluetooth sunrpc ip_conntrack_netbios_ns ipt_REJECT xt_state
ip_conntrack nfnetlink xt_tcpudp iptable_filter ip_tables x_tables video button
battery ac lp parport_pc parport usblp ohci1394 ieee1394 usb_storage uhci_hcd
ehci_hcd floppy sg snd_emu10k1 snd_rawmidi snd_ac97_codec snd_ac97_bus
snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_pcm_oss snd_mixer_oss
bt878 tuner tda9887 msp3400 snd_pcm snd_seq_device snd_timer snd_page_alloc
snd_util_mem snd_hwdep snd bttv video_buf ir_common compat_ioctl32 i2c_algo_bit
v4l2_common soundcore btcx_risc tveeprom tg3 videodev emu10k1_gp gameport
i2c_i801 i2c_core dm_snapshot dm_zero dm_mirror dm_mod ata_piix ext3 jbd ahci
libata sd_mod scsi_mod
Jun 21 21:04:53 knutjorgen kernel: CPU:    0
Jun 21 21:04:53 knutjorgen kernel: EIP:    0060:[<f8a31234>]    Not tainted VLI
Jun 21 21:04:53 knutjorgen kernel: EFLAGS: 00010082   (2.6.17-1.2138_FC5 #1) 
Jun 21 21:04:53 knutjorgen kernel: EIP is at snd_seq_delete_all_ports+0x60/0x176
[snd_seq]
Jun 21 21:04:53 knutjorgen kernel: eax: 00000044   ebx: f767a768   ecx: c06bcfd0
  edx: f7f7a000
Jun 21 21:04:53 knutjorgen kernel: esi: f767a768   edi: f56d67e8   ebp: f56d6760
  esp: f4edef30
Jun 21 21:04:53 knutjorgen kernel: ds: 007b   es: 007b   ss: 0068
Jun 21 21:04:53 knutjorgen kernel: Process pmidi (pid: 2994, threadinfo=f4ede000
task=f7f7a000)
Jun 21 21:04:53 knutjorgen kernel: Stack: f8a32432 f767a768 f56d67e8 f56d67fc
f56d67f0 00000282 22222222 22222222 
Jun 21 21:04:53 knutjorgen kernel:        f56d6760 f75973e0 f75973e0 f4ebc734
f8a2c1bc f56d6760 f8a2c26e 00000000 
Jun 21 21:04:53 knutjorgen kernel:        f7597568 00000008 f56d6760 f8a2c2bc
00000008 c045e00e 00000000 f71d0340 
Jun 21 21:04:53 knutjorgen kernel: Call Trace:
Jun 21 21:04:53 knutjorgen kernel:  <f8a2c1bc> seq_free_client1+0x8/0x7e
[snd_seq]  <f8a2c26e> seq_free_client+0x3c/0x78 [snd_seq]
Jun 21 21:04:53 knutjorgen kernel:  <f8a2c2bc> snd_seq_release+0x12/0x31
[snd_seq]  <c045e00e> __fput+0xb2/0x158
Jun 21 21:04:53 knutjorgen kernel:  <c045b940> filp_close+0x52/0x59  <c0402cb3>
syscall_call+0x7/0xb
Jun 21 21:04:53 knutjorgen kernel: Code: 00 00 74 6d 8b 9d 88 00 00 00 8b b5 8c
00 00 00 8b 43 04 39 f0 74 1c 89 74 24 04 89 44 24 08 c7 04 24 32 24 a3 f8 e8 8f
b7 9e c7 <0f> 0b 3a 00 1d 24 a3 f8 8b 06 39 d8 74 1c 89 5c 24 04 89 44 24 
Jun 21 21:04:53 knutjorgen kernel: EIP: [<f8a31234>]
snd_seq_delete_all_ports+0x60/0x176 [snd_seq] SS:ESP 0068:f4edef30
Jun 21 21:04:53 knutjorgen kernel:  <0>Fatal exception: panic in 5 seconds
Comment 5 Knut J BJuland 2006-06-22 10:37:11 EDT

*** This bug has been marked as a duplicate of 194597 ***

Note You need to log in before you can comment on or make changes to this bug.