Bug 1962099 - Creating a VM from a template via console is using the v1alpha3 API with a v1 VM manifest
Summary: Creating a VM from a template via console is using the v1alpha3 API with a v1...
Keywords:
Status: CLOSED DUPLICATE of bug 1958811
Alias: None
Product: Container Native Virtualization (CNV)
Classification: Red Hat
Component: User Experience
Version: 4.8.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Tal Nisan
QA Contact: Oded Ramraz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-19 10:13 UTC by Sarah Bennert
Modified: 2021-05-24 13:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-24 13:24:55 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sarah Bennert 2021-05-19 10:13:11 UTC
Description of problem:

Creating a VM from a template via console is using the v1alpha3 API with a v1 VM manifest, which fails.


Version-Release number of selected component (if applicable):
# Openshift cluster
4.8.0-fc.2

# HCO Operator
registry.redhat.io/container-native-virtualization/hyperconverged-cluster-operator@sha256:508529059070b9fc4cb701416f7911e6954b15424af7e68ff161e93fda805dd3
hyperconverged-cluster-operator-container-v4.8.0-51

# SSP Operator
registry.redhat.io/container-native-virtualization/kubevirt-ssp-operator@sha256:572b2ed7d34667520874e99402863f3011cd6f13452600451e715a4230c1f9b1
kubevirt-ssp-operator-container-v4.8.0-33


How reproducible:
100%

Steps to Reproduce:
1. Create a VM from a template in console
2.
3.

Actual results:

POST https://console.example/api/kubernetes/apis/kubevirt.io/v1alpha3/namespaces/default/virtualmachines

{
  "kind": "Status",
  "apiVersion": "v1",
  "metadata": {
    
  },
  "status": "Failure",
  "message": "the API version in the data (kubevirt.io/v1) does not match the expected API version (kubevirt.io/v1alpha3)",
  "reason": "BadRequest",
  "code": 400
}


Expected results:
VM Created


Additional info:

Comment 1 Tal Nisan 2021-05-24 13:24:55 UTC

*** This bug has been marked as a duplicate of bug 1958811 ***


Note You need to log in before you can comment on or make changes to this bug.