Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1962208

Summary: [OSP16.2] Validation overcloud-service-status shouldn't be triggered in pre-upgrade group
Product: Red Hat OpenStack Reporter: David Vallee Delisle <dvd>
Component: openstack-tripleo-validationsAssignee: David Vallee Delisle <dvd>
Status: CLOSED ERRATA QA Contact: nlevinki <nlevinki>
Severity: medium Docs Contact:
Priority: medium    
Version: 16.2 (Train)CC: dvd, gchamoul, jfrancoa, jjoyce, jschluet, mschuppe, nlevinki, slinaber, tvignaud
Target Milestone: betaKeywords: Patch, Triaged
Target Release: 16.2 (Train on RHEL 8.4)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-validations-11.5.1-2.20210521024806.c906f18.el8ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1962205 Environment:
Last Closed: 2021-09-15 07:15:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version: Train
Embargoed:
Bug Depends On: 1962205    
Bug Blocks:    

Description David Vallee Delisle 2021-05-19 13:59:48 UTC
+++ This bug was initially created as a clone of Bug #1962205 +++

Description of problem:

When executing the pre-upgrade validation group the validation overcloud-service-status is triggered. However, the execution of this group takes currently place right before starting with the Overcloud Upgrade FFU 13 -> 16.1 : https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/16.1/html-single/framework_for_upgrades_13_to_16.1/index#proc-validating-the-pre-upgrade-requirements_initial-steps

At this point, the Undercloud is upgraded to OSP16.1 while the Overcloud is still in OSP13, therefore the validation fails with:

{
    "hosts": {
        "undercloud": {
            "_ansible_no_log": false,
            "action": "fail",
            "changed": false,
            "failed": true,
            "msg": "At least one of the assertion failed.\n            nova-consoleauth should be removed on controller-2.redhat.local\n                      nova-consoleauth should be removed on controller-1.redhat.local\n                      nova-consoleauth should be removed on controller-0.redhat.local\n                  \n"              
        }
    },
    "name": "Asserted failure",
    "status": "FAILED"
}

But this situation is correct, as the nodes haven't been upgraded yet. For this reason, the pre-upgrade group should be removed from the validation: 

https://github.com/openstack/tripleo-validations/blob/stable/train/playbooks/overcloud-service-status.yaml#L11-L16

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 6 errata-xmlrpc 2021-09-15 07:15:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Red Hat OpenStack Platform (RHOSP) 16.2 enhancement advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2021:3483