Bug 1962225 - [OSP16.1][Validation] collect-flavors-and-verify-profiles fails with exception during pre-upgrade group in FFU
Summary: [OSP16.1][Validation] collect-flavors-and-verify-profiles fails with exceptio...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 16.1 (Train)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z7
: 16.1 (Train on RHEL 8.2)
Assignee: David Vallee Delisle
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks: 1966412
TreeView+ depends on / blocked
 
Reported: 2021-05-19 14:31 UTC by Jose Luis Franco
Modified: 2021-12-09 20:20 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-validations-11.3.2-1.20210531133305.4db92ba.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1966412 (view as bug list)
Environment:
Last Closed: 2021-12-09 20:19:39 UTC
Target Upstream Version: Train


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 793054 0 None MERGED [train-only] Inventory doesn't contain admin password 2021-05-31 10:46:26 UTC
Red Hat Issue Tracker OSP-3999 0 None None None 2021-11-18 11:32:48 UTC
Red Hat Product Errata RHBA-2021:3762 0 None None None 2021-12-09 20:20:01 UTC

Description Jose Luis Franco 2021-05-19 14:31:04 UTC
Description of problem:

During the execution of the pre-upgade group right before starting with the upgrade of the Overcloud nodes, the validation collect-flavors-and-verify-profiles fails with the following output:

{
    "hosts": {
        "undercloud": {
            "_ansible_no_log": false,
            "action": "check_flavors",
            "failed": true,
            "msg": "An unhandled exception occurred while running the lookup plugin 'roles_info'. Error was a <class 'swiftclient.exceptions.ClientException'>, original message: Authorization Failure. A user and password or token is required."
        }
    },
    "name": "Collect and check the flavors",
    "status": "FAILED"
}

A reproducer can be created if required. I'll try to post more logging information in a follow up comment.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 David Vallee Delisle 2021-05-25 15:10:52 UTC
This is happenning because the "password" variable is not in the variables anymore.

Looking for a possible solution like using os_auth_token instead.

Comment 19 errata-xmlrpc 2021-12-09 20:19:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Red Hat OpenStack Platform 16.1.7 (Train) bug fix and enhancement advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3762


Note You need to log in before you can comment on or make changes to this bug.