Bug 1962452 - python-pyphi fails to build with Python 3.10: ImportError: cannot import name 'Iterable' from 'collections'
Summary: python-pyphi fails to build with Python 3.10: ImportError: cannot import name...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pyphi
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ankur Sinha (FranciscoD)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1969099 (view as bug list)
Depends On:
Blocks: F35FTBFS F35FailsToInstall F36FTBFS F36FailsToInstall PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-05-20 05:48 UTC by Tomáš Hrnčiar
Modified: 2021-08-18 18:47 UTC (History)
4 users (show)

Fixed In Version: python-pyphi-1.2.0-12.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-18 18:47:56 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-05-20 05:48:08 UTC
python-pyphi fails to build with Python 3.10.0b1.

Traceback (most recent call last):
  File "/usr/lib/python3.10/site-packages/sphinx/config.py", line 327, in eval_config_file
    execfile_(filename, namespace)
  File "/usr/lib/python3.10/site-packages/sphinx/util/pycompat.py", line 88, in execfile_
    exec(code, _globals)
  File "/builddir/build/BUILD/pyphi-1.2.0/docs/conf.py", line 28, in <module>
    from pyphi import __version__, __author__
  File "/builddir/build/BUILD/pyphi-1.2.0/pyphi/__init__.py", line 77, in <module>
    from . import (actual, constants, convert, db, examples, jsonify, macro,
  File "/builddir/build/BUILD/pyphi-1.2.0/pyphi/actual.py", line 27, in <module>
    from . import (Direction, compute, config, connectivity, constants, exceptions,
  File "/builddir/build/BUILD/pyphi-1.2.0/pyphi/compute/__init__.py", line 28, in <module>
    from .subsystem import (sia, phi, evaluate_cut, ConceptStyleSystem,
  File "/builddir/build/BUILD/pyphi-1.2.0/pyphi/compute/subsystem.py", line 11, in <module>
    from .. import Direction, config, connectivity, memory, utils
  File "/builddir/build/BUILD/pyphi-1.2.0/pyphi/memory.py", line 14, in <module>
    from . import config, constants, db
  File "/builddir/build/BUILD/pyphi-1.2.0/pyphi/db.py", line 9, in <module>
    from collections import Iterable
ImportError: cannot import name 'Iterable' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)

The deprecated aliases to Collections Abstract Base Classes were removed from the collections module.
https://docs.python.org/3.10/whatsnew/changelog.html#python-3-10-0-alpha-6
https://bugs.python.org/issue37324

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/02197853-python-pyphi/

For all our attempts to build python-pyphi with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-pyphi/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2021-06-04 20:13:23 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 2 Miro Hrončok 2021-06-07 22:58:12 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 3 Miro Hrončok 2021-06-08 11:30:52 UTC
*** Bug 1969099 has been marked as a duplicate of this bug. ***

Comment 4 Miro Hrončok 2021-06-15 20:28:24 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 5 Ben Cotton 2021-08-10 13:03:00 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.


Note You need to log in before you can comment on or make changes to this bug.