Bug 1962465 - python-zeep: FTBFS in Fedora rawhide
Summary: python-zeep: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-zeep
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Georg Sauthoff
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: PYTHON3.10 F35FTBFS
TreeView+ depends on / blocked
 
Reported: 2021-05-20 06:46 UTC by Tomáš Hrnčiar
Modified: 2021-05-25 20:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-25 20:16:00 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-05-20 06:46:32 UTC
Description of problem:
Package python-zeep fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
4.0.0-2.fc34

Steps to Reproduce:
koji build --scratch f35 python-zeep-4.0.0-2.fc34.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-zeep

Comment 1 Georg Sauthoff 2021-05-25 20:16:00 UTC
Hm, did a scratch build with a tiny extra bit of debugging and that succeeded in rawhide:
https://koji.fedoraproject.org/koji/taskinfo?taskID=68730632

A regular re-build succeeded as well:
https://koji.fedoraproject.org/koji/taskinfo?taskID=68731214

Ok, so the build that failed ran on s390x, my scratch build ran on x86_64 and the other regular re-build ran on ppc64le.

Thus, I submitted another scratch-build for s390x which succeeded as well:
https://koji.fedoraproject.org/koji/taskinfo?taskID=68731775

So not another weird s390x issue, this time.

Thus, I'm closing this issue, as it was likely caused by a dependency which was fixed since the last build failure.


Note You need to log in before you can comment on or make changes to this bug.