Bug 1962608 - failed to configure pod interface: error while waiting on flows for pod: timed out waiting for OVS flows
Summary: failed to configure pod interface: error while waiting on flows for pod: time...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.7
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.7.z
Assignee: Federico Paolinelli
QA Contact: Dan Brahaney
URL:
Whiteboard:
: 1994615 (view as bug list)
Depends On: 1952819
Blocks: 1985347
TreeView+ depends on / blocked
 
Reported: 2021-05-20 11:13 UTC by Federico Paolinelli
Modified: 2021-10-11 09:47 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1952819
: 1985347 (view as bug list)
Environment:
Last Closed: 2021-08-03 17:56:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift ovn-kubernetes pull 547 0 None open Bug 1962608: ensure missed events are handled during a reconnection 2021-06-22 01:00:49 UTC
Red Hat Product Errata RHBA-2021:2903 0 None None None 2021-08-03 17:56:49 UTC

Comment 3 Dan Brahaney 2021-07-27 17:04:37 UTC
Attempted replication of error as described here in original bug report https://bugzilla.redhat.com/show_bug.cgi?id=1952819#c13

After following steps, blocking traffic with iptables and then unblocking, it appears to be working as expected, with similar results to those detailed by Anurag in original bug here https://bugzilla.redhat.com/show_bug.cgi?id=1952819#c14

 
oc logs -c ovnkube-master ovnkube-master-7fc91 | grep -i "openshift-monitoring/prometheus-k8s-0"
I0727 10:24:36.400321       1 kube.go:61] Setting annotations map[k8s.ovn.org/pod-networks:{"default":{"ip_addresses":["10.128.2.14/23"],"mac_address":"0a:58:0a:81:21:4c","gateway_ips":["10.128.2.1"],"ip_address":"10.128.2.14/23","gateway_ip":"10.128.2.1"}}] on pod openshift-monitoring/prometheus-k8s-0
I0727 10:24:36.402945       1 pods.go:302] [openshift-monitoring/prometheus-k8s-0] addLogicalPort took 115.352688ms
I0727 12:45:22.746453       1 pods.go:91] Deleting pod: openshift-monitoring/prometheus-k8s-0   <<<<<<<<<<<<<<<<<<<<<<<<<<<<<
I0727 12:46:48.256944       1 kube.go:61] Setting annotations map[k8s.ovn.org/pod-networks:{"default":{"ip_addresses":["10.128.2.15/23"],"mac_address":"0a:58:0a:81:21:4d","gateway_ips":["10.128.2.1"],"ip_address":"10.128.2.15/23","gateway_ip":"10.128.2.1"}}] on pod openshift-monitoring/prometheus-k8s-0
I0727 12:47:01.566984        1 pods.go:302] [openshift-monitoring/prometheus-k8s-0] addLogicalPort took 103.284433ms   <<<<<<<<<<<<


Marking as verified.

Comment 4 Dan Brahaney 2021-07-27 17:07:31 UTC
Attempted replication of error as described here in original bug report https://bugzilla.redhat.com/show_bug.cgi?id=1952819#c13

After following steps, blocking traffic with iptables and then unblocking, it appears to be working as expected, with similar results to those detailed by Anurag in original bug here https://bugzilla.redhat.com/show_bug.cgi?id=1952819#c14

 
oc logs -c ovnkube-master ovnkube-master-7fc91 | grep -i "openshift-monitoring/prometheus-k8s-0"
I0727 10:24:36.400321       1 kube.go:61] Setting annotations map[k8s.ovn.org/pod-networks:{"default":{"ip_addresses":["10.128.2.14/23"],"mac_address":"0a:58:0a:81:21:4c","gateway_ips":["10.128.2.1"],"ip_address":"10.128.2.14/23","gateway_ip":"10.128.2.1"}}] on pod openshift-monitoring/prometheus-k8s-0
I0727 10:24:36.402945       1 pods.go:302] [openshift-monitoring/prometheus-k8s-0] addLogicalPort took 115.352688ms
I0727 12:45:22.746453       1 pods.go:91] Deleting pod: openshift-monitoring/prometheus-k8s-0   <<<<<<<<<<<<<<<<<<<<<<<<<<<<<
I0727 12:46:48.256944       1 kube.go:61] Setting annotations map[k8s.ovn.org/pod-networks:{"default":{"ip_addresses":["10.128.2.15/23"],"mac_address":"0a:58:0a:81:21:4d","gateway_ips":["10.128.2.1"],"ip_address":"10.128.2.15/23","gateway_ip":"10.128.2.1"}}] on pod openshift-monitoring/prometheus-k8s-0
I0727 12:47:01.566984        1 pods.go:302] [openshift-monitoring/prometheus-k8s-0] addLogicalPort took 103.284433ms   <<<<<<<<<<<<


Marking as verified.

Comment 6 errata-xmlrpc 2021-08-03 17:56:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.22 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:2903

Comment 7 Kenjiro Nakayama 2021-08-19 00:36:16 UTC
*** Bug 1994615 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.