Bug 196263 - sip is preventing python from updating
Summary: sip is preventing python from updating
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-22 09:39 UTC by Ian Laurie
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 22:05:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ian Laurie 2006-06-22 09:39:00 UTC
Description of problem:
python-devel-2.4.3-4.FC5.i386 updates python-devel-2.4.2-3.2.1.i386, but the
iupdate won't happen because sip-devel-4.3.1-1.2.1.i386 needs the old python-devel.

Version-Release number of selected component (if applicable):
See above.

How reproducible:
Always.

Steps to Reproduce:
1. Launch pup.
2. Python won't update.
3.
  
Actual results:
sip-devel is blocking the python update.

Expected results:
python should be able to update.

Additional info:
I have ended up with 2 versions of python installed:

zaurak# rpm -q python
python-2.4.2-3.2.1
python-2.4.3-4.FC5

This cannot be a good thing.

Comment 1 Ngo Than 2006-09-28 22:05:28 UTC
i don't see how sip could break the update. The deps of sip/sip-devel looks 
ok. I assume it's bug in pirut


Note You need to log in before you can comment on or make changes to this bug.